aboutsummaryrefslogtreecommitdiff
path: root/utils/ntfs-3g/Makefile
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2021-08-31 12:18:20 +0200
committerRosen Penev <rosenp@gmail.com>2021-09-01 14:10:34 -0700
commit555546e3d335256bf1d82abf16a94f999c248ff5 (patch)
treed58e30c0bfee39cf4a38a88b62697282a6d070a1 /utils/ntfs-3g/Makefile
parent036f9ff78fdb9175e596ed8ef4ddf83077b5fc63 (diff)
ntfs-3g: bump to 2021.8.22 (CVE fixes)
Upstream announced new release which includes fixes for 21 CVEs (see [1]). Upstream changed the symlink "mkfs.ntfs" to respect "--sbin-dir". So this commit adjusts this likewise in the Makefile. [1] https://www.openwall.com/lists/oss-security/2021/08/30/1 Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'utils/ntfs-3g/Makefile')
-rw-r--r--utils/ntfs-3g/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/utils/ntfs-3g/Makefile b/utils/ntfs-3g/Makefile
index 40d38e80e..e69c98663 100644
--- a/utils/ntfs-3g/Makefile
+++ b/utils/ntfs-3g/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ntfs-3g
-PKG_VERSION:=2017.3.23
-PKG_RELEASE:=4
+PKG_VERSION:=2021.8.22
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_ntfsprogs-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://www.tuxera.com/opensource/
-PKG_HASH:=3e5a021d7b761261836dcb305370af299793eedbded731df3d6943802e1262d5
+PKG_HASH:=55b883aa05d94b2ec746ef3966cb41e66bed6db99f22ddd41d1b8b94bb202efb
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_LICENSE:=GPL-2.0-only LGPL-2.1-or-later
@@ -205,12 +205,11 @@ fi
endef
define Package/ntfs-3g-utils/install
- $(INSTALL_DIR) $(1)/sbin
- $(LN) ../usr/sbin/mkntfs $(1)/sbin/mkfs.ntfs
- $(INSTALL_DIR) $(1)/usr/bin
+ rm -f $(PKG_INSTALL_DIR)/usr/sbin/mkfs.ntfs
+ $(INSTALL_DIR) $(1)/usr/{bin,sbin}
$(FIND) $(PKG_INSTALL_DIR)/usr/bin/ -type f ! -regex '.*[^/]*ntfs-3g[^/]*' -exec $(INSTALL_BIN) {} $(1)/usr/bin/ \;
- $(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
+ $(LN) mkntfs $(1)/usr/sbin/mkfs.ntfs
endef
$(eval $(call BuildPackage,ntfs-3g))