aboutsummaryrefslogtreecommitdiff
path: root/utils/ntfs-3g/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-10-21 19:04:53 +0200
committerJo-Philipp Wich <jo@mein.io>2016-10-21 19:04:53 +0200
commit117bc23432604cf1568e6f9f5e2bcf84759708b9 (patch)
treebe7597b1cd0007d5aa24cb57292825120bb57691 /utils/ntfs-3g/Makefile
parent9f8dd657a1ee6ef0af496d89d3aef4f9595f13bf (diff)
ntfs-3g: ship /sbin/mount.ntfs compatibility symlink
Like on other common desktop Linux distributions, ship an /sbin/mount.ntfs symlink in addition to the /sbin/mount.ntfs-3g one in order to let wrapper programs successfully call external mount helpers by the filesystem name. The assumption is that /sbin/mount.ntfs is only ever called by util-linux mount and other mount-wrappers when kernel NTFS support is not available, means shipping the additional symlink will not interfere with kernel mode NTFS support. This commit is mainly intended to prepare transparent fs-tools support for mounting fuse filesystems, with focus on ntfs-3g in particular. Please see http://git.lede-project.org/f027c68 for the corresponding fs-tools support code. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'utils/ntfs-3g/Makefile')
-rw-r--r--utils/ntfs-3g/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/utils/ntfs-3g/Makefile b/utils/ntfs-3g/Makefile
index 07708c629..82674dd5c 100644
--- a/utils/ntfs-3g/Makefile
+++ b/utils/ntfs-3g/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ntfs-3g
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_VERSION:=2015.3.14
PKG_SOURCE:=$(PKG_NAME)_ntfsprogs-$(PKG_VERSION).tgz
@@ -169,6 +169,7 @@ define Package/ntfs-3g/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libntfs-3g.so.* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/sbin
$(CP) $(PKG_INSTALL_DIR)/sbin/mount.ntfs-3g $(1)/sbin/
+ $(CP) $(PKG_INSTALL_DIR)/sbin/mount.ntfs-3g $(1)/sbin/mount.ntfs
endef
define Package/ntfs-3g/postinst