aboutsummaryrefslogtreecommitdiff
path: root/utils/ncdu
diff options
context:
space:
mode:
authorCharles Lehner <cel@celehner.com>2015-05-02 09:40:43 -0400
committerCharles Lehner <cel@celehner.com>2015-05-14 15:52:08 -0400
commit851c9c9da733f43f85c2c874e8cd239179eeea6c (patch)
treed2ada724daf04b027c92947ce36fd146945882df /utils/ncdu
parent6f43c044f140651138f7fcede94d5f20c7fdc79e (diff)
ncdu: update to 1.11
- Add patch to get WEXITSTATUS and WIFEXITED defined The issue is fixed in upstream's development repo, so the patch won't be needed with ncdu's next release. - Depend on more commonly used libncurses instead of libncursesw - Enable parallel build - Update copyright Signed-off-by: Charles Lehner <cel@celehner.com>
Diffstat (limited to 'utils/ncdu')
-rw-r--r--utils/ncdu/Makefile11
-rw-r--r--utils/ncdu/patches/010-add_sys_wait.patch10
2 files changed, 17 insertions, 4 deletions
diff --git a/utils/ncdu/Makefile b/utils/ncdu/Makefile
index edd852758..39f6b78ef 100644
--- a/utils/ncdu/Makefile
+++ b/utils/ncdu/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,14 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ncdu
-PKG_VERSION:=1.10
+PKG_VERSION:=1.11
PKG_RELEASE=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://dev.yorhel.nl/download
-PKG_MD5SUM:=7535decc8d54eca811493e82d4bfab2d
+PKG_MD5SUM:=9e44240a5356b029f05f0e70a63c4d12
PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING
@@ -26,7 +27,7 @@ define Package/ncdu
SUBMENU:=Filesystem
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=+libncursesw
+ DEPENDS:=+libncurses
TITLE:=ncurses disk usage viewer
MAINTAINER:=Charles Lehner <celehner1@gmail.com>
URL:=http://dev.yorhel.nl/ncdu
@@ -38,6 +39,8 @@ define Package/ncdu/description
directories and show percentages of disk usage with ncurses library.
endef
+CONFIGURE_ARGS += --with-ncurses
+
define Package/ncdu/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ncdu $(1)/usr/bin/
diff --git a/utils/ncdu/patches/010-add_sys_wait.patch b/utils/ncdu/patches/010-add_sys_wait.patch
new file mode 100644
index 000000000..dfc06117e
--- /dev/null
+++ b/utils/ncdu/patches/010-add_sys_wait.patch
@@ -0,0 +1,10 @@
+--- a/src/shell.c
++++ b/src/shell.c
+@@ -33,6 +33,7 @@
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <sys/wait.h>
+
+ void shell_draw() {
+ char *full_path;
+ int res;