aboutsummaryrefslogtreecommitdiff
path: root/utils/mt-st
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-08-02 16:41:18 -0700
committerRosen Penev <rosenp@gmail.com>2019-08-02 16:59:21 -0700
commit4cda68c72b54885e0465411ba8667e543771d2e2 (patch)
tree84a156a3477b7130ed30b69e755d30f95e7665df /utils/mt-st
parent15884f28a1ea30f8b0dc0b6fa5b295653460f871 (diff)
mt-st: Add missing header
New version of musl no longer includes this header internally. Removed several unnecessary variables in Makefile. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/mt-st')
-rw-r--r--utils/mt-st/Makefile8
-rw-r--r--utils/mt-st/patches/010-sysmacros.patch10
2 files changed, 13 insertions, 5 deletions
diff --git a/utils/mt-st/Makefile b/utils/mt-st/Makefile
index aab5e751e..71bfdcf99 100644
--- a/utils/mt-st/Makefile
+++ b/utils/mt-st/Makefile
@@ -9,14 +9,13 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mt-st
PKG_VERSION:=1.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)
-PKG_SOURCE_VERSION:=$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.ibiblio.org/pub/Linux/system/backup/
PKG_HASH:=945cb4f3d9957dabe768f5941a9148b746396836c797b25f020c84319ba8170d
+PKG_MAINTAINER:=Giuseppe Magnotta <giuseppe.magnotta@gmail.com>
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
@@ -26,7 +25,6 @@ define Package/mt-st
CATEGORY:=Utilities
TITLE:=Magnetic tape control tools for Linux SCSI tapes
URL:=http://ftp.ibiblio.org/pub/Linux/system/backup/
- MAINTAINER:=Giuseppe Magnotta <giuseppe.magnotta@gmail.com>
endef
define Package/mt-st/description
diff --git a/utils/mt-st/patches/010-sysmacros.patch b/utils/mt-st/patches/010-sysmacros.patch
new file mode 100644
index 000000000..8e4b37378
--- /dev/null
+++ b/utils/mt-st/patches/010-sysmacros.patch
@@ -0,0 +1,10 @@
+--- a/mt.c
++++ b/mt.c
+@@ -21,6 +21,7 @@
+ #include <sys/types.h>
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <sys/utsname.h>
+
+ #include "mtio.h"