aboutsummaryrefslogtreecommitdiff
path: root/utils/mpremote
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-10-15 22:56:42 +0800
committerTianling Shen <cnsztl@gmail.com>2023-11-02 00:38:21 +0800
commit3085608448e97130b59f3c82da2a582ec6794103 (patch)
treebcaa85b61335f87c96870f87ab40b75b5f724686 /utils/mpremote
parentd10b26525c29a8fc694f3bab0db3a678b4bf3ebd (diff)
micropython-mpremote: Update to 1.21.0, rename package, move into utils
This renames the package to mpremote and moves it into utils, as this is a command-line utility and not a Python/MicroPython library. This also adds a test.sh script for the packages feed CI. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'utils/mpremote')
-rw-r--r--utils/mpremote/Makefile43
-rw-r--r--utils/mpremote/patches/001-no-importlib_metadata.patch5
-rw-r--r--utils/mpremote/test.sh5
3 files changed, 53 insertions, 0 deletions
diff --git a/utils/mpremote/Makefile b/utils/mpremote/Makefile
new file mode 100644
index 000000000..af69d8088
--- /dev/null
+++ b/utils/mpremote/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2023 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpremote
+PKG_VERSION:=1.21.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=mpremote
+PKG_HASH:=65bc94511f6ff499e901ab59462a5f0744ff7e2cf71d8c75700d14a89c54ed61
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_BUILD_DEPENDS:=python-hatchling/host python-hatch-requirements-txt/host python-hatch-vcs/host
+
+include ../../lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/python/python3-package.mk
+
+define Package/mpremote
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Interacting remotely with MicroPython devices
+ URL:=https://github.com/micropython/micropython
+ DEPENDS:=+python3-light +python3-urllib +python3-pyserial
+endef
+
+define Package/mpremote/description
+This CLI tool provides an integrated set of utilities to remotely
+interact with and automate a MicroPython device over a serial
+connection.
+endef
+
+$(eval $(call Py3Package,mpremote))
+$(eval $(call BuildPackage,mpremote))
+$(eval $(call BuildPackage,mpremote-src))
diff --git a/utils/mpremote/patches/001-no-importlib_metadata.patch b/utils/mpremote/patches/001-no-importlib_metadata.patch
new file mode 100644
index 000000000..6f5fc4921
--- /dev/null
+++ b/utils/mpremote/patches/001-no-importlib_metadata.patch
@@ -0,0 +1,5 @@
+--- a/requirements.txt
++++ b/requirements.txt
+@@ -1,2 +1 @@
+ pyserial >= 3.3
+-importlib_metadata >= 1.4
diff --git a/utils/mpremote/test.sh b/utils/mpremote/test.sh
new file mode 100644
index 000000000..3010c24c4
--- /dev/null
+++ b/utils/mpremote/test.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+[ "$1" = mpremote ] || exit 0
+
+mpremote version | grep -Fx "mpremote $PKG_VERSION"