aboutsummaryrefslogtreecommitdiff
path: root/utils/mhz
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-06-17 08:47:39 +0200
committerTianling Shen <cnsztl@gmail.com>2023-06-17 18:34:06 +0800
commit89123b308f98de6e6e77a1bf21586c8fafc83413 (patch)
treea526c4cbbbae566034cb158bb66b014bd3ba2fe0 /utils/mhz
parent90fca4694b27203629820579030eb0dae8d3f516 (diff)
mhz: add new package
mhz is a tool for mathematically calculating the current CPU frequency, it has proven to be a really good help while developing CPU frequency scaling solutions as it allows to independently prove that scaling actually works. Now that the author has added a license we can package it for the all to use. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'utils/mhz')
-rw-r--r--utils/mhz/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/utils/mhz/Makefile b/utils/mhz/Makefile
new file mode 100644
index 000000000..fa8108917
--- /dev/null
+++ b/utils/mhz/Makefile
@@ -0,0 +1,33 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mhz
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL=https://github.com/wtarreau/mhz.git
+PKG_SOURCE_DATE:=2023-06-17
+PKG_SOURCE_VERSION:=11aac2399780a1f7ea9f007b14af0464797d5cf1
+PKG_MIRROR_HASH:=b3ea0c9e6f111755c4207addef0ea210ace86bc6910c959c6fc489026897676f
+
+PKG_MAINTAINER:=Robert Marko <robimarko@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/mhz
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=CPU frequency measurement utility
+endef
+
+define Package/mhz/description
+ Tool to mathematically calculate the current CPU frequency.
+endef
+
+define Package/mhz/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/mhz $(1)/usr/sbin/mhz
+endef
+
+$(eval $(call BuildPackage,mhz))