aboutsummaryrefslogtreecommitdiff
path: root/utils/mariadb
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-02-22 14:50:50 -0800
committerRosen Penev <rosenp@gmail.com>2021-02-22 15:12:04 -0800
commit8a62f2ea6b8462fea85905490099290983914cc5 (patch)
treee8760612d1364855480296cbd7867fe57840bbc4 /utils/mariadb
parent9543f72c7755e87686c5ac1e46565d8268d1d0ff (diff)
mariadb: update to 10.4.18
Remove uClibc depends. It's gone now. Remove CMAKE_INSTALL to avoid installing to InstallDev. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/mariadb')
-rw-r--r--utils/mariadb/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/utils/mariadb/Makefile b/utils/mariadb/Makefile
index 7230fe43c..03bdd51c3 100644
--- a/utils/mariadb/Makefile
+++ b/utils/mariadb/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mariadb
-PKG_VERSION:=10.4.17
+PKG_VERSION:=10.4.18
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -18,7 +18,7 @@ PKG_SOURCE_URL := \
https://ftp.yz.yamagata-u.ac.jp/pub/dbms/mariadb/$(PKG_NAME)-$(PKG_VERSION)/source \
https://downloads.mariadb.org/interstitial/$(PKG_NAME)-$(PKG_VERSION)/source
-PKG_HASH:=a7b104e264311cd46524ae546ff0c5107978373e4a01cf7fd8a241454548d16e
+PKG_HASH:=330d9e8273002fc92f0f3f3f9b08157a3cab1265a0f114adeb6235e4283a0d3e
PKG_MAINTAINER:=Michal Hrusecky <Michal@Hrusecky.net>
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING THIRDPARTY
@@ -33,8 +33,6 @@ HOST_BUILD_DEPENDS:=libxml2/host
# Without libevent2 tests/async_queries sporadically fails on the bots
PKG_BUILD_DEPENDS:=libevent2 mariadb/host
-CMAKE_INSTALL:=1
-
CONF_DIR:=/etc/mysql
PLUGIN_DIR:=/usr/lib/mariadb/plugin
SHARE_DIR:=/usr/share/mariadb
@@ -178,8 +176,7 @@ MARIADB_COMMON_DEPENDS := \
+libatomic \
+libopenssl \
+libstdcpp \
- +zlib \
- @!USE_UCLIBC
+ +zlib
# Pass CPPFLAGS in the CFLAGS as otherwise the build system will
# ignore them.
@@ -478,11 +475,6 @@ define Build/Prepare
$(foreach p,$(MARIADB_DISABLE_PLUGINS),$(call Package/mariadb/disable/plugin,$(PKG_BUILD_DIR),$(p));)
endef
-# Define Build/InstallDev, otherwise build system starts installing files into
-# staging area, which would interfere with mariadb-connector-c.
-define Build/InstallDev
-endef
-
define Package/mariadb-client/install
$(INSTALL_DIR) $(1)/usr/bin
$(foreach b,$(MARIADB_CLIENT),$(call Package/mariadb/install/bin,$(1),$(b));)