aboutsummaryrefslogtreecommitdiff
path: root/utils/mariadb
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2019-11-17 16:12:32 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2019-11-17 17:17:04 +0100
commit4a67c844db9c1e80bb385f40c137586cc5fba652 (patch)
tree836bf9a119e85dc0978ef7819999f0814ec20a71 /utils/mariadb
parentc1964dd8d2684e1f5d546124e1bff49057f4b282 (diff)
mariadb: small plugins fixes
This adds a few lines to the BuildPlugin routine to install some missing files for auth_pam as well as ha_spider. It also adds a postinstall script that updates the ownership of a directory used by auth_pam. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'utils/mariadb')
1 files changed, 17 insertions, 1 deletions
diff --git a/utils/mariadb/Makefile b/utils/mariadb/Makefile
index bca45dc9a..2cef40083 100644
--- a/utils/mariadb/Makefile
+++ b/utils/mariadb/Makefile
@@ -545,10 +545,27 @@ This package provides the $(1) plugin.
define Package/mariadb-server-plugin-$(subst _,-,$(1))/install
$(INSTALL_DIR) $$(1)$(PLUGIN_DIR)
$(call Package/mariadb/install/plugin,$$(1),$(1))
+ifeq ($(1),auth_pam)
+ $(CP) $(PKG_INSTALL_DIR)$(PLUGIN_DIR)/auth_pam_tool_dir \
+ $$(1)$(PLUGIN_DIR)
+endif
+ifeq ($(1),ha_spider)
+ $(INSTALL_DIR) $$(1)$(SHARE_DIR)
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)$(SHARE_DIR)/install_spider.sql \
+ $$(1)$(SHARE_DIR)
+endif
endef
$$(eval $$(call BuildPackage,mariadb-server-plugin-$(subst _,-,$(1))))
endef
+define Package/mariadb-server-plugin-auth-pam/postinst
+#!/bin/sh
+if [ -z "$${IPKG_INSTROOT}" ]; then
+ chown mariadb /usr/lib/mariadb/plugin/auth_pam_tool_dir > /dev/null 2>&1
+fi
+exit 0
+endef
+
$(eval $(call HostBuild))
$(eval $(call BuildPackage,mariadb-client))
$(eval $(call BuildPackage,mariadb-client-base))
@@ -580,4 +597,3 @@ $(eval $(call BuildPlugin,server_audit,))
$(eval $(call BuildPlugin,simple_password_check,))
$(eval $(call BuildPlugin,sql_errlog,))
$(eval $(call BuildPlugin,wsrep_info,))
-