aboutsummaryrefslogtreecommitdiff
path: root/utils/lxc
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-08 00:12:26 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-02-08 00:12:26 +0100
commit8baab925628b74866a8976c516ad6840988756ee (patch)
tree9b78642a7bf762fd35a905fc1027d21bd2e1385e /utils/lxc
parent27bd80910a9fa638b6748164661cd1cabc54fdeb (diff)
lxc: use generic autoreconf fixup
Use the generic autoreconf facility to pickup proper variants of autoconf, automake and libtool. Remove the unneeded Build/Configure override. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'utils/lxc')
-rw-r--r--utils/lxc/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/utils/lxc/Makefile b/utils/lxc/Makefile
index 3adfd5de9..943f7a4a3 100644
--- a/utils/lxc/Makefile
+++ b/utils/lxc/Makefile
@@ -19,7 +19,9 @@ PKG_MD5SUM:=4aad3aee84b42faa194e44091d723a3b
PKG_BUILD_DEPENDS:=lua
PKG_BUILD_PARALLEL:=1
+
PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
@@ -118,11 +120,6 @@ MAKE_FLAGS += \
LUA_INSTALL_CMOD="/usr/lib/lua" \
LUA_INSTALL_LMOD="/usr/lib/lua"
-define Build/Configure
- ( cd $(PKG_BUILD_DIR); ./autogen.sh );
- $(call Build/Configure/Default)
-endef
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/lxc/