aboutsummaryrefslogtreecommitdiff
path: root/utils/lxc
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-09-10 14:39:17 +0200
committerLuka Perkov <luka@openwrt.org>2014-09-11 01:02:04 +0200
commit1614bed10b2e3bc3b8163e5a31455d4e20f850e6 (patch)
treebdf0691e613b78eb28fd396a1ae1d9beb0d35983 /utils/lxc
parent34fd74553a6ae4688bf0718b8c71a9d49416514d (diff)
lxc: add configuration section
Signed-off-by: Luka Perkov <luka@openwrt.org>
Diffstat (limited to 'utils/lxc')
-rw-r--r--utils/lxc/Config.in15
-rw-r--r--utils/lxc/Makefile6
2 files changed, 20 insertions, 1 deletions
diff --git a/utils/lxc/Config.in b/utils/lxc/Config.in
new file mode 100644
index 000000000..c52ba532e
--- /dev/null
+++ b/utils/lxc/Config.in
@@ -0,0 +1,15 @@
+menu "Configuration"
+ depends on PACKAGE_lxc
+
+config LXC_KERNEL_OPTIONS
+ bool "Enable kernel support for LXC"
+ default n
+ select KERNEL_CGROUPS
+ select KERNEL_NAMESPACES
+ select KERNEL_LXC_MISC
+ help
+ Select needed kernel options for LXC related utilities. Options
+ include cgroups, namespaces and other miscellaneous options. These
+ options unfortunately can not be installed as a module.
+
+endmenu
diff --git a/utils/lxc/Makefile b/utils/lxc/Makefile
index a613352df..97d79835e 100644
--- a/utils/lxc/Makefile
+++ b/utils/lxc/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lxc
PKG_VERSION:=1.0.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://linuxcontainers.org/downloads/
@@ -49,6 +49,10 @@ define Package/lxc
MENU:=1
endef
+define Package/lxc/config
+ source "$(SOURCE)/Config.in"
+endef
+
define Package/lxc/description
LXC is the userspace control package for Linux Containers, a lightweight
virtual system mechanism sometimes described as "chroot on steroids".