aboutsummaryrefslogtreecommitdiff
path: root/utils/lsof
diff options
context:
space:
mode:
authorMaxim Storchak <m.storchak@gmail.com>2023-12-09 03:12:47 +0200
committerTianling Shen <cnsztl@gmail.com>2023-12-13 14:16:16 +0800
commitf3c27a3a25afd43bb55da78e2faddc26578c85b9 (patch)
tree32d918a7e5b47cfe545f9778ec8707c2ad2c2796 /utils/lsof
parent0e1ddd2417bf2321a972eb578945d7f5eb6f9bb9 (diff)
lsof: update to 4.99.0
- drop the patches that don't apply anymore - update build commads Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
Diffstat (limited to 'utils/lsof')
-rw-r--r--utils/lsof/Makefile43
-rw-r--r--utils/lsof/patches/000-disable-man.patch18
-rw-r--r--utils/lsof/patches/001-lsof_makefile.patch13
-rw-r--r--utils/lsof/patches/002-lsof_noportmap.patch18
-rw-r--r--utils/lsof/patches/003-lsof_selinux.patch11
-rw-r--r--utils/lsof/patches/004-lsof_ccv.patch12
6 files changed, 24 insertions, 91 deletions
diff --git a/utils/lsof/Makefile b/utils/lsof/Makefile
index a49b053c4..11a774dce 100644
--- a/utils/lsof/Makefile
+++ b/utils/lsof/Makefile
@@ -1,6 +1,4 @@
#
-# Copyright (C) 2007-2015 OpenWrt.org
-#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
@@ -9,17 +7,17 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=lsof
-PKG_VERSION:=4.94.0
+PKG_VERSION:=4.99.0
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).linux.tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/lsof-org/lsof/releases/download/$(PKG_VERSION)
-PKG_HASH:=c41709c2543ecf9de1e950795790a9786a2f225e51c3cc53d6a9a256f872472b
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION).linux
+PKG_HASH:=180e6284aff184d94d273e34f7264edc2af849c07b1c5d6a4183d4d402734245
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
PKG_LICENSE:=Unique
-PKG_LICENSE_FILES:=00README
+PKG_LICENSE_FILES:=COPYING
include $(INCLUDE_DIR)/package.mk
@@ -31,36 +29,7 @@ define Package/lsof
URL:=http://people.freebsd.org/~abe/
endef
-ifneq ($(CONFIG_IPV6),n)
- LINUX_CLIB_IPV6=-DHASIPv6
-else
- LINUX_CLIB_IPV6=
-endif
-
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/tirpc
-TARGET_LDFLAGS += -ltirpc
-
-define Build/Configure
- $(SED) 's/rpc\/rpc/\/tirpc\/rpc\/rpc/g' $(PKG_BUILD_DIR)/Configure
- cd $(PKG_BUILD_DIR); \
- LINUX_CLIB="-DGLIBCV=2 $(LINUX_CLIB_IPV6)" \
- LSOF_CC="$(TARGET_CC)" \
- LSOF_VSTR="$(LINUX_VERSION)" \
- LSOF_CFGF="$(TARGET_CFLAGS)" \
- LSOF_CFGL="$(TARGET_LDFLAGS)" \
- LSOF_AR="$(TARGET_CROSS)ar cr" \
- LSOF_RANLIB="$(TARGET_CROSS)ranlib" \
- LSOF_INCLUDE="$(STAGING_DIR)/usr/include" \
- ./Configure -n linux
-endef
-
-define Build/Compile
- LSOF_HOST="none" \
- LSOF_LOGNAME="none" \
- LSOF_SYSINFO="none" \
- LSOF_USER="none" \
- $(MAKE) -C $(PKG_BUILD_DIR)
-endef
+CONFIGURE_ARGS += --without-selinux
define Package/lsof/install
$(INSTALL_DIR) $(1)/usr/bin
diff --git a/utils/lsof/patches/000-disable-man.patch b/utils/lsof/patches/000-disable-man.patch
new file mode 100644
index 000000000..cf9a391f0
--- /dev/null
+++ b/utils/lsof/patches/000-disable-man.patch
@@ -0,0 +1,18 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -208,13 +208,8 @@ EXTRA_DIST += 00.README.FIRST 00CREDITS
+ # Testing
+ EXTRA_DIST += tests/00README tests/TestDB tests/CkTestDB tests/Makefile tests/LsofTest.h check.bash
+
+-# Manpages
+-lsof.man: Lsof.8 version 00DIALECTS
+- soelim < Lsof.8 > $@
+-man8_MANS = lsof.man
+-EXTRA_DIST += Lsof.8
+ # Fix distcheck error
+ clean-local:
+ rm -rf lsof.man
+ distclean-local:
+- rm -rf lockf_owner.h lockf.h
+\ No newline at end of file
++ rm -rf lockf_owner.h lockf.h
diff --git a/utils/lsof/patches/001-lsof_makefile.patch b/utils/lsof/patches/001-lsof_makefile.patch
deleted file mode 100644
index eb2b73519..000000000
--- a/utils/lsof/patches/001-lsof_makefile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/lib/Makefile.skel
-+++ b/lib/Makefile.skel
-@@ -21,8 +21,8 @@ OBJ= ckkv.o cvfs.o dvch.o fino.o isfn.o
- all: ${LIB}
-
- ${LIB}: ${OBJ}
-- ${AR}
-- ${RANLIB}
-+ ${AR} ${LIB} ${OBJ}
-+ ${RANLIB} ${LIB}
-
- clean: FRC
- rm -f ${LIB} ${OBJ} errs Makefile.bak a.out core
diff --git a/utils/lsof/patches/002-lsof_noportmap.patch b/utils/lsof/patches/002-lsof_noportmap.patch
deleted file mode 100644
index 825f255b7..000000000
--- a/utils/lsof/patches/002-lsof_noportmap.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/print.c
-+++ b/print.c
-@@ -160,6 +160,7 @@ endnm(sz)
- static void
- fill_portmap()
- {
-+#if !defined __UCLIBC__ || (defined __UCLIBC__ && defined __UCLIBC_HAS_RPC__)
- char buf[128], *cp, *nm;
- CLIENT *c;
- int h, port, pr;
-@@ -278,6 +279,7 @@ fill_portmap()
- Pth[pr][h] = pt;
- }
- clnt_destroy(c);
-+#endif
- }
- #endif /* !defined(HASNORPC_H) */
-
diff --git a/utils/lsof/patches/003-lsof_selinux.patch b/utils/lsof/patches/003-lsof_selinux.patch
deleted file mode 100644
index ee1426d12..000000000
--- a/utils/lsof/patches/003-lsof_selinux.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Configure
-+++ b/Configure
-@@ -2991,7 +2991,7 @@ return(0); }
- LSOF_TMP1=1
- fi # }
- fi # }
-- if test $LSOF_TMP1 -eq 1 # {
-+ if test 0 -eq 1 # {
- then
- LSOF_CFGF="$LSOF_CFGF -DHASSELINUX"
- LSOF_CFGL="$LSOF_CFGL -lselinux"
diff --git a/utils/lsof/patches/004-lsof_ccv.patch b/utils/lsof/patches/004-lsof_ccv.patch
deleted file mode 100644
index 1f4e57c52..000000000
--- a/utils/lsof/patches/004-lsof_ccv.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/Configure
-+++ b/Configure
-@@ -2850,6 +2850,9 @@ LOCKF_OWNER4
- if test "X$LSOF_CC" = "X" # {
- then
- LSOF_CC=cc
-+ fi # }
-+ if test "X$LSOF_CCV" = "X" # {
-+ then
- LSOF_CCV=`$LSOF_CC -v 2>&1 | sed -n 's/.*version \(.*\)/\1/p'`
- fi # }
- if test "X$LINUX_CONF_CC" = "X" # {