aboutsummaryrefslogtreecommitdiff
path: root/utils/lsof
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-08-15 18:52:30 -0700
committerRosen Penev <rosenp@gmail.com>2018-08-15 18:53:58 -0700
commit7e86dedef1d340b8943531c178796fc59772d2e9 (patch)
treeb59770cc01c1d2254a23152e283c0f7d13a2de06 /utils/lsof
parent4c99cab7d3bb49123d4121ae93d9ea4dd8d3bf08 (diff)
lsof: Fix dead URL + cosmetic fixes
Removed some whitespace and refreshed patches, which was forgotten during the bump. No actual changes so no release bump. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/lsof')
-rw-r--r--utils/lsof/Makefile7
-rw-r--r--utils/lsof/patches/003-lsof_selinux.patch2
-rw-r--r--utils/lsof/patches/004-lsof_ccv.patch2
3 files changed, 6 insertions, 5 deletions
diff --git a/utils/lsof/Makefile b/utils/lsof/Makefile
index 7b36b6798..30d327687 100644
--- a/utils/lsof/Makefile
+++ b/utils/lsof/Makefile
@@ -13,9 +13,10 @@ PKG_VERSION:=4.91
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=https://www.mirrorservice.org/sites/lsof.itap.purdue.edu/pub/tools/unix/lsof/ ftp://sunsite.ualberta.ca/pub/Mirror/lsof/ ftp://ftp.fu-berlin.de/pub/unix/tools/lsof
+PKG_SOURCE_URL:=https://www.mirrorservice.org/sites/lsof.itap.purdue.edu/pub/tools/unix/lsof/ ftp://ftp.fu-berlin.de/pub/unix/tools/lsof
PKG_HASH:=c9da946a525fbf82ff80090b6d1879c38df090556f3fe0e6d782cb44172450a3
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
+
PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
PKG_LICENSE:=Unique
PKG_LICENSE_FILES:=00README
@@ -59,7 +60,7 @@ define Build/Configure
./Configure -n linux
endef
-define Build/Compile
+define Build/Compile
LSOF_HOST="none" \
LSOF_LOGNAME="none" \
LSOF_SYSINFO="none" \
@@ -67,7 +68,7 @@ define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)
endef
-define Package/lsof/install
+define Package/lsof/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/lsof $(1)/usr/bin
endef
diff --git a/utils/lsof/patches/003-lsof_selinux.patch b/utils/lsof/patches/003-lsof_selinux.patch
index f3168e579..0aafec8d1 100644
--- a/utils/lsof/patches/003-lsof_selinux.patch
+++ b/utils/lsof/patches/003-lsof_selinux.patch
@@ -2,7 +2,7 @@ diff --git a/Configure b/Configure
index e4a25a2..3a6e78b 100755
--- a/Configure
+++ b/Configure
-@@ -2923,7 +2923,7 @@ return(0); }
+@@ -2976,7 +2976,7 @@ return(0); }
LSOF_TMP1=1
fi # }
fi # }
diff --git a/utils/lsof/patches/004-lsof_ccv.patch b/utils/lsof/patches/004-lsof_ccv.patch
index e2f162ba7..e0b4f2718 100644
--- a/utils/lsof/patches/004-lsof_ccv.patch
+++ b/utils/lsof/patches/004-lsof_ccv.patch
@@ -2,7 +2,7 @@ diff --git a/Configure b/Configure
index 3a6e78b..a2946c6 100755
--- a/Configure
+++ b/Configure
-@@ -2788,6 +2788,9 @@ LOCKF_OWNER4
+@@ -2841,6 +2841,9 @@ LOCKF_OWNER4
if test "X$LSOF_CC" = "X" # {
then
LSOF_CC=cc