aboutsummaryrefslogtreecommitdiff
path: root/utils/lolcat
diff options
context:
space:
mode:
authorRui Salvaterra <rsalvaterra@gmail.com>2021-06-25 09:04:23 +0100
committerRui Salvaterra <rsalvaterra@gmail.com>2021-06-28 09:05:19 +0100
commitd2582939ad63b3646ce26db737867538e8f7f9eb (patch)
treee14318064578a4aad3167fb0f7b33c5acf76105f /utils/lolcat
parentb609c35513718a7a445bbcaf58a145ab3e50d72e (diff)
lolcat: add package
A pure C implementation of lolcat, probably the lightest out there. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
Diffstat (limited to 'utils/lolcat')
-rw-r--r--utils/lolcat/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/utils/lolcat/Makefile b/utils/lolcat/Makefile
new file mode 100644
index 000000000..644bd25f8
--- /dev/null
+++ b/utils/lolcat/Makefile
@@ -0,0 +1,29 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lolcat
+PKG_VERSION:=1.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/jaseg/lolcat/tar.gz/refs/tags/v$(PKG_VERSION)?
+PKG_HASH:=b6e1a0e24479fbdd4eb907531339e2cafc0c00b78d19caf70e8377b8b7546331
+
+PKG_MAINTAINER:=Rui Salvaterra <rsalvaterra@gmail.com>
+PKG_LICENSE:=WTFPL
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/lolcat
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=A cat variant with rainbow colour output
+ URL:=https://github.com/jaseg/lolcat
+endef
+
+define Package/lolcat/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/lolcat $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,lolcat))