aboutsummaryrefslogtreecommitdiff
path: root/utils/lcd4linux
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2023-05-23 08:30:06 +0200
committerFlorian Eckert <fe@dev.tdt.de>2023-05-23 08:41:12 +0200
commit917ea9d214fe4a6ef8e000c50761ac6d302f8162 (patch)
treeafd2859d833369b43d14bd2abcb21359b8093d9f /utils/lcd4linux
parente90bb8ea9ad6a36deab4bda7ea3d7f022a22f039 (diff)
lcd4linux: fix build error for custom build
This change fixes the following build error: hecking that generated files are newer than configure... done configure: error: conditional "ANSICXX" was never defined. Usually this means the macro was only invoked conditionally. make[2]: *** [Makefile:300: /home/feckert/openwrt/build_dir/target-x86_64_musl/lcd4linux-custom/lcd4linux-2019-07-19-0b83bb3a/.configured_a17fb5ef857664f03cd0ce37cc5ea591] Error 1 make[2]: Leaving directory '/home/feckert/feeds/packages/utils/lcd4linux' time: package/feeds/packages/lcd4linux/custom/compile#15.43#0.79#16.92 ERROR: package/feeds/packages/lcd4linux failed to build (build variant: custom). make[1]: *** [package/Makefile:120: package/feeds/packages/lcd4linux/compile] Error 1 make[1]: Leaving directory '/home/feckert/openwrt' make: *** [/home/feckert/openwrt/include/toplevel.mk:231: package/feeds/packages/lcd4linux/compile] Error 2 Signed-off-by: Florian Eckert <fe@dev.tdt.de> Suggested-by: Oskari Rauta <oskari.rauta@gmail.com>
Diffstat (limited to 'utils/lcd4linux')
-rw-r--r--utils/lcd4linux/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/utils/lcd4linux/Makefile b/utils/lcd4linux/Makefile
index 4f42576da..74265172a 100644
--- a/utils/lcd4linux/Makefile
+++ b/utils/lcd4linux/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lcd4linux
-PKG_RELEASE:=8
+PKG_RELEASE:=9
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/feckert/lcd4linux
@@ -195,6 +195,10 @@ $(call Package/lcd4linux/Default/description)
endef
+CONFIGURE_VARS+= \
+ ANSICXX_TRUE=yes \
+ am__fastdepCXX_TRUE=yes
+
CONFIGURE_ARGS+= \
--disable-rpath