aboutsummaryrefslogtreecommitdiff
path: root/utils/irqbalance
diff options
context:
space:
mode:
authorMarc Benoit <marcb62185@gmail.com>2020-03-03 07:48:27 -0500
committerMarc Benoit <marcb62185@gmail.com>2020-03-03 07:58:27 -0500
commitb6078559cdd47b4def5bb44dd46759a8591f3e4f (patch)
tree62f023a917c2a4d83e16319a5c5dcdd9b51a1f06 /utils/irqbalance
parent0afea2e06bbd2885218f1dfe7d6b50f9bc399a43 (diff)
irqbalance: support reload_config & start later
Added support for reload_config This service does not need to start so early (even before the netwrok is up). Start it after the device is mostly up and operational. Compile-tested on: ipq806x Runtime-tested on: ipq806x Signed-off-by: Marc Benoit <marcb62185@gmail.com>
Diffstat (limited to 'utils/irqbalance')
-rw-r--r--utils/irqbalance/Makefile2
-rw-r--r--utils/irqbalance/files/irqbalance.init10
2 files changed, 9 insertions, 3 deletions
diff --git a/utils/irqbalance/Makefile b/utils/irqbalance/Makefile
index a0ebac2da..88172afdd 100644
--- a/utils/irqbalance/Makefile
+++ b/utils/irqbalance/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=irqbalance
PKG_VERSION:=1.6.0
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_PROTO:=git
diff --git a/utils/irqbalance/files/irqbalance.init b/utils/irqbalance/files/irqbalance.init
index 3f968d075..638dcb39f 100644
--- a/utils/irqbalance/files/irqbalance.init
+++ b/utils/irqbalance/files/irqbalance.init
@@ -1,8 +1,15 @@
#!/bin/sh /etc/rc.common
-START=11
+START=90
+STOP=10
+
USE_PROCD=1
+service_triggers()
+{
+ procd_add_reload_trigger "irqbalance"
+}
+
start_service() {
local enabled
config_load 'irqbalance'
@@ -25,4 +32,3 @@ start_service() {
procd_set_param respawn
procd_close_instance
}
-