aboutsummaryrefslogtreecommitdiff
path: root/utils/irqbalance
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2020-06-17 23:29:13 +0300
committerHannu Nyman <hannu.nyman@iki.fi>2020-06-17 23:29:13 +0300
commit4f0c847828b9602d12d13059a5e8bb159120dcb7 (patch)
tree1471841fce58618523098f06429e6d929a7e7c6c /utils/irqbalance
parentc8187f7f16e6fbbe396bfb25061f93a55a9bfa5b (diff)
irqbalance: fix socket directory and create it
Irqbalance defines /run/irqbalance dir for its socket communication between irqbalance and its UI. /run does not exist in OpenWrt (although it is defined by the Linux FHS), so the socket creation fails. Although we do not compile UI and thus the issue is not critical to us, fix the directory location. Additionally, the creation is originally handled by a systemd init script that we do not use. * patch source to define dir as /var/run/irqbalance * create the dir in the procd init script. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'utils/irqbalance')
-rw-r--r--utils/irqbalance/Makefile2
-rw-r--r--utils/irqbalance/files/irqbalance.init2
-rw-r--r--utils/irqbalance/patches/110-fix-runtime-socket-directory.patch22
3 files changed, 25 insertions, 1 deletions
diff --git a/utils/irqbalance/Makefile b/utils/irqbalance/Makefile
index 15924e279..6f657f850 100644
--- a/utils/irqbalance/Makefile
+++ b/utils/irqbalance/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=irqbalance
PKG_VERSION:=1.6.0
-PKG_RELEASE:=9
+PKG_RELEASE:=10
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_PROTO:=git
diff --git a/utils/irqbalance/files/irqbalance.init b/utils/irqbalance/files/irqbalance.init
index 638dcb39f..0f587e158 100644
--- a/utils/irqbalance/files/irqbalance.init
+++ b/utils/irqbalance/files/irqbalance.init
@@ -16,6 +16,8 @@ start_service() {
config_get_bool enabled irqbalance enabled 0
[ "$enabled" -gt 0 ] || return 0
+ mkdir -p /var/run/irqbalance
+
# 10 is the default
config_get interval irqbalance interval 10
diff --git a/utils/irqbalance/patches/110-fix-runtime-socket-directory.patch b/utils/irqbalance/patches/110-fix-runtime-socket-directory.patch
new file mode 100644
index 000000000..6429f1678
--- /dev/null
+++ b/utils/irqbalance/patches/110-fix-runtime-socket-directory.patch
@@ -0,0 +1,22 @@
+--- a/irqbalance.h
++++ b/irqbalance.h
+@@ -158,7 +158,7 @@ extern unsigned int log_mask;
+ #endif /* HAVE_LIBSYSTEMD */
+
+ #define SOCKET_PATH "irqbalance"
+-#define SOCKET_TMPFS "/run/irqbalance/"
++#define SOCKET_TMPFS "/var/run/irqbalance/"
+
+ #endif /* __INCLUDE_GUARD_IRQBALANCE_H_ */
+
+--- a/ui/irqbalance-ui.h
++++ b/ui/irqbalance-ui.h
+@@ -8,7 +8,7 @@
+ #include <glib-unix.h>
+
+ #define SOCKET_PATH "irqbalance"
+-#define SOCKET_TMPFS "/run/irqbalance"
++#define SOCKET_TMPFS "/var/run/irqbalance"
+
+ #define STATS "stats"
+ #define SET_SLEEP "settings sleep "