aboutsummaryrefslogtreecommitdiff
path: root/utils/irqbalance/Makefile
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2017-02-08 00:26:58 +0200
committerHannu Nyman <hannu.nyman@iki.fi>2017-02-08 00:26:58 +0200
commitc5913bd12d73c4c781b79c16246a8e9c8d236b8f (patch)
tree5037a9a819856b400787b5b17614020adf2d3b99 /utils/irqbalance/Makefile
parentccf0595fc61f11b45b4558568934b740a54e4556 (diff)
irqbalance: add package
The purpose of irqbalance is to distribute hardware interrupts across processors/cores on a multiprocessor/-core system in order to increase performance. This initial implementation of the package uses external glib2, which is a large dependency. Only the cmd-line tool is compiled and installed. Run-tested with ipq806x / R7800. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'utils/irqbalance/Makefile')
-rw-r--r--utils/irqbalance/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/utils/irqbalance/Makefile b/utils/irqbalance/Makefile
new file mode 100644
index 000000000..7de1db0fd
--- /dev/null
+++ b/utils/irqbalance/Makefile
@@ -0,0 +1,52 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=irqbalance
+PKG_VERSION:=1.2.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/Irqbalance/irqbalance.git
+PKG_SOURCE_VERSION:=0e0dd4cfe5464de2f81eaef504eab7183f1fb030
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_LICENSE:=GPLv2
+
+PKG_MAINTAINER:=Hannu Nyman <hannu.nyman@iki.fi>
+
+PKG_FIXUP:=autoreconf
+PKG_REMOVE_FILES:=autogen.sh
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/irqbalance
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=+glib2
+ TITLE:=IRQ usage balancing for multi-core systems
+ URL:=https://github.com/Irqbalance/irqbalance
+endef
+
+define Package/irqbalance/description
+ The purpose of irqbalance is to distribute hardware interrupts across
+ processors/cores on a multiprocessor/multicore system in order to
+ increase performance.
+endef
+
+CONFIGURE_ARGS+= \
+ --disable-numa \
+ --with-libcap_ng=no \
+ --with-systemd=no \
+ --with-glib2=yes
+
+define Package/irqbalance/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/irqbalance $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,irqbalance))