aboutsummaryrefslogtreecommitdiff
path: root/utils/irqbalance/Makefile
diff options
context:
space:
mode:
authorMarc Benoit <marcb62185@gmail.com>2020-02-24 18:16:58 -0500
committerMarc Benoit <marcb62185@gmail.com>2020-02-29 07:20:47 -0500
commitbdcb872a40e4567bc57c45299a0df5efad65207f (patch)
treeb2acd58adce9ed604458eb23ffea45f6b3e4d29b /utils/irqbalance/Makefile
parentfa44a58546bdbddc5f549891f513a29fc3234746 (diff)
irqbalance: upgrade to 1.6.0
Upgraded from 1.2.0 to 1.6.0 to pick up all the latest fixes and improvements irqbalance made glib2 mandatory since 1.3.0, but is using very little of it. glib2 linked statically to minimize the impact. 1.2.0 size: 33,619 1.6.0 size: 99,539 ~# irqbalance --version irqbalance version 1.6.0 ~# ldd /usr/sbin/irqbalance /lib/ld-musl-armhf.so.1 (0xb6f5f000) libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb6f43000) libc.so => /lib/ld-musl-armhf.so.1 (0xb6f5f000) ~# opkg info irqbalance Package: irqbalance Version: 1.6.0-6 Depends: libc Status: install user installed Architecture: arm_cortex-a7_neon-vfpv4 Installed-Time: 1582839249 Compile-tested: ipq806x/R7800 & ipq40xx/GL-B1300 Run-tested: ipq806x/R7800 & ipq40xx/GL-B1300 Signed-off-by: Marc Benoit <marcb62185@gmail.com>
Diffstat (limited to 'utils/irqbalance/Makefile')
-rw-r--r--utils/irqbalance/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/utils/irqbalance/Makefile b/utils/irqbalance/Makefile
index 5523a19b2..19116c63b 100644
--- a/utils/irqbalance/Makefile
+++ b/utils/irqbalance/Makefile
@@ -5,14 +5,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=irqbalance
-PKG_VERSION:=1.2.0
-PKG_RELEASE:=4
+PKG_VERSION:=1.6.0
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/Irqbalance/irqbalance.git
-PKG_SOURCE_VERSION:=0e0dd4cfe5464de2f81eaef504eab7183f1fb030
-PKG_MIRROR_HASH:=c826e78babfc26f777a5791b2a6ea95b61453ba3e3c5803d4428cc803216bc5c
+PKG_SOURCE_VERSION:=b47eea84cbb93f533b0cba2f1aaf9ca4da8706b9
+PKG_MIRROR_HASH:=ce1cd84cd315492d4260786735eae81e49515ec3eebe652920a7dc57b93c0c2c
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_LICENSE:=GPLv2
@@ -23,9 +23,13 @@ PKG_REMOVE_FILES:=autogen.sh
PKG_BUILD_PARALLEL:=1
+# -liconv due to glib2, to be revisited later
+include $(INCLUDE_DIR)/nls.mk
+
include $(INCLUDE_DIR)/package.mk
define Package/irqbalance
+ PKG_BUILD_DEPENDS:=glib2
SECTION:=utils
CATEGORY:=Utilities
TITLE:=IRQ usage balancing for multi-core systems
@@ -42,7 +46,12 @@ CONFIGURE_ARGS+= \
--disable-numa \
--with-libcap_ng=no \
--with-systemd=no \
- --without-glib2
+ --without-irqbalance-ui \
+ --enable-static=glib2
+
+CONFIGURE_VARS += \
+ GLIB2_LIBS="$(STAGING_DIR)/usr/lib/libglib-2.0.a \
+ $(STAGING_DIR)/usr/lib/libiconv-stub/lib/libiconv.a"
define Package/irqbalance/install
$(INSTALL_DIR) $(1)/usr/sbin