aboutsummaryrefslogtreecommitdiff
path: root/utils/irqbalance/Makefile
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2019-06-02 12:29:17 +0300
committerHannu Nyman <hannu.nyman@iki.fi>2019-06-02 12:43:08 +0300
commit982c389732d2d0589d15cfc1835e289275140c8c (patch)
treeae2c712cec5c5b0d45e66efc8fb07ed85a8b9c4d /utils/irqbalance/Makefile
parentdf14fa949ff49a7c16ac8ac230c0947fb38cc113 (diff)
irqbalance: add support for uci config
Add support for uci config file. Only a global 'enabled" switch has been implemented so far. * Default config disables irqbalance initially, so that there is no change with the previous behaviour (and the possibly existing separate launch scripts in people's builds). Config file and init script can be later extended for irqbalance options like the oneshot mode or the evaluation interval (Also change the init file to use tabs) Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'utils/irqbalance/Makefile')
-rw-r--r--utils/irqbalance/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/utils/irqbalance/Makefile b/utils/irqbalance/Makefile
index 59536d04d..5523a19b2 100644
--- a/utils/irqbalance/Makefile
+++ b/utils/irqbalance/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=irqbalance
PKG_VERSION:=1.2.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_PROTO:=git
@@ -49,6 +49,8 @@ define Package/irqbalance/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/irqbalance $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/irqbalance.init $(1)/etc/init.d/irqbalance
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_DATA) ./files/irqbalance.config $(1)/etc/config/irqbalance
endef
$(eval $(call BuildPackage,irqbalance))