aboutsummaryrefslogtreecommitdiff
path: root/utils/irqbalance/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-06-09 15:30:40 -0700
committerHannu Nyman <hannu.nyman@iki.fi>2022-07-19 16:19:05 +0300
commit59cadc7c65d5540b3e1bba26dfcd782cad98a5fe (patch)
tree8081dc37ff943416beebb3f30795673a1ee359c1 /utils/irqbalance/Makefile
parente702a6605805b1160341bfc949ec1de4687af06d (diff)
irqbalance: add meson
Fixes compilation when libiconv is missing. Also remove pthread from glibc. No longer needed. Cleanup Makefile for consistency between packages. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/irqbalance/Makefile')
-rw-r--r--utils/irqbalance/Makefile43
1 files changed, 10 insertions, 33 deletions
diff --git a/utils/irqbalance/Makefile b/utils/irqbalance/Makefile
index 6347ee153..09a744a6e 100644
--- a/utils/irqbalance/Makefile
+++ b/utils/irqbalance/Makefile
@@ -8,24 +8,18 @@ PKG_NAME:=irqbalance
PKG_VERSION:=1.9.0
PKG_RELEASE:=$(AUTORELEASE)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/Irqbalance/irqbalance.git
-PKG_SOURCE_VERSION:=80d5fbb947debe221e4c23c0ee0f4f2b89a99443
+PKG_SOURCE_VERSION:=v$(PKG_VERSION)
PKG_MIRROR_HASH:=9af2e51d2696bc51400223dee2009071bee5f12b3a5050f18c7de23632e2190d
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_LICENSE:=GPLv2
PKG_MAINTAINER:=Hannu Nyman <hannu.nyman@iki.fi>
-
-PKG_FIXUP:=autoreconf
-PKG_REMOVE_FILES:=autogen.sh
-
-PKG_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/nls.mk
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=COPYING
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+include $(INCLUDE_DIR)/meson.mk
PKG_BUILD_DEPENDS += glib2
@@ -43,34 +37,17 @@ define Package/irqbalance/description
increase performance.
endef
-CONFIGURE_ARGS+= \
- --disable-numa \
- --with-libcap_ng=no \
- --with-systemd=no \
- --without-irqbalance-ui \
- --enable-static=glib2
-
-GLIB2_LIBS="$(STAGING_DIR)/usr/lib/libglib-2.0.a"
-
-ifeq ($(CONFIG_BUILD_NLS),y)
- GLIB2_LIBS += $(INTL_LDFLAGS) -lintl
-endif
-
-ifeq ($(CONFIG_USE_GLIBC),y)
- GLIB2_LIBS += -lpthread
-endif
-
-CONFIGURE_VARS += \
- GLIB2_LIBS="$(GLIB2_LIBS) \
- $(ICONV_LDFLAGS) -liconv"
-
define Package/irqbalance/conffiles
/etc/config/irqbalance
endef
+MESON_ARGS += \
+ -Dcapng=disabled \
+ -Dui=disabled
+
define Package/irqbalance/install
$(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/irqbalance $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/irqbalance $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/irqbalance.init $(1)/etc/init.d/irqbalance
$(INSTALL_DIR) $(1)/etc/config