aboutsummaryrefslogtreecommitdiff
path: root/utils/io
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2019-07-22 15:03:57 +0200
committerHauke Mehrtens <hauke.mehrtens@intel.com>2019-07-24 13:57:09 +0200
commit90df0f3e241dc233c3121dfc5e1be937c6c987bc (patch)
tree69d9333e6aa0610f600989b7a239130396ae53d9 /utils/io
parente7faabcf119a8543e0633e47e2da7300d0116a43 (diff)
io: Open /dev/mem with O_SYNC for uncached access
Only when /dev/mem is opened with O_SYNC the write and *read* is done uncached. We saw wrong values read out from the hardware without setting O_SYNC, the busybox devmem tool showed different values, when O_SYNC is also set for the io tool, it reads out the same values as devmem. When looking at the drivers/char/mem.c file in the kernel it is behaving differently based on the O_DSYNC flag. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
Diffstat (limited to 'utils/io')
-rw-r--r--utils/io/Makefile2
-rw-r--r--utils/io/src/io.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/utils/io/Makefile b/utils/io/Makefile
index a861e7477..fe3f779b2 100644
--- a/utils/io/Makefile
+++ b/utils/io/Makefile
@@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=io
-PKG_RELEASE:=1
+PKG_RELEASE:=2
include $(INCLUDE_DIR)/package.mk
diff --git a/utils/io/src/io.c b/utils/io/src/io.c
index 257205404..519291213 100644
--- a/utils/io/src/io.c
+++ b/utils/io/src/io.c
@@ -343,7 +343,7 @@ main (int argc, char **argv)
printf("Attempting to map 0x%lx bytes at address 0x%08lx\n",
real_len, real_addr);
- mfd = open("/dev/mem", (memfunc == MEM_READ) ? O_RDONLY : O_RDWR);
+ mfd = open("/dev/mem", (memfunc == MEM_READ) ? (O_RDONLY | O_SYNC) : (O_RDWR | O_SYNC));
if (mfd == -1) {
perror("open /dev/mem");
fprintf(stderr, "Is CONFIG_DEVMEM activated?\n");