aboutsummaryrefslogtreecommitdiff
path: root/utils/io/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2019-11-07 21:06:04 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-11-13 23:25:03 +0100
commitb46d21a54ee5a073f5d5082e7d90cf07113c8a9a (patch)
tree8a51e8ac7ebf7e2ba9226b54039ed9bc203f0fa8 /utils/io/Makefile
parent9936e16b724b4388204e21e2d4c3f49283d980eb (diff)
io: Add TARGET_LDFLAGS to fix PIE
Add the OpenWrt TARGET_LDFLAGS to the compile command to activate PIE support for the io tool when it is activated globally in OpenWrt. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
Diffstat (limited to 'utils/io/Makefile')
-rw-r--r--utils/io/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/utils/io/Makefile b/utils/io/Makefile
index c572554d0..b588b3347 100644
--- a/utils/io/Makefile
+++ b/utils/io/Makefile
@@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=io
-PKG_RELEASE:=3
+PKG_RELEASE:=4
include $(INCLUDE_DIR)/package.mk
@@ -25,7 +25,8 @@ define Package/io/description
endef
define Build/Compile
- $(TARGET_CC) $(TARGET_CFLAGS) -Wall $(PKG_BUILD_DIR)/io.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
+ $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) -Wall \
+ $(PKG_BUILD_DIR)/io.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
endef
define Package/io/install