aboutsummaryrefslogtreecommitdiff
path: root/utils/idevicerestore
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-12-13 23:00:06 -0800
committerRosen Penev <rosenp@gmail.com>2019-12-16 12:24:01 -0800
commit9fbe1c247e6d705e24896de3050271ae0024a7b5 (patch)
tree5f9ca6af14d4dc88837bd1b66ce97a8cacb2f755 /utils/idevicerestore
parent0b51b4c46947b68e99f542541d916d382cd34a9c (diff)
idevicerestore: Add package
Allows to flash an iOS device without using iTunes. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/idevicerestore')
-rw-r--r--utils/idevicerestore/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/utils/idevicerestore/Makefile b/utils/idevicerestore/Makefile
new file mode 100644
index 000000000..9c61338cd
--- /dev/null
+++ b/utils/idevicerestore/Makefile
@@ -0,0 +1,47 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=idevicerestore
+PKG_SOURCE_DATE:=2019-12-13
+PKG_SOURCE_VERSION:=a2a6ad16d2c3157153aae7e0835e478237b01507
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL=https://github.com/libimobiledevice/idevicerestore
+PKG_MIRROR_HASH:=522bd35a0a4e8cc64ef9b29716e88efd84829e81c9c00ce9170fef285ac4b137
+
+PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=COPYING
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/idevicerestore
+ SECTION:=utils
+ CATEGORY:=Utilities
+ SUBMENU:=libimobiledevice
+ TITLE:=Restore/upgrade firmware of iOS devices
+ URL:=https://github.com/libimobiledevice/idevicerestore
+ DEPENDS:=+libirecovery +libzip +libcurl +usbmuxd
+endef
+
+define Package/idevicerestore/description
+ The idevicerestore tool allows to restore firmware files to iOS devices.
+ It is a full reimplementation of all granular steps which are performed
+ during restore of a firmware to a device.
+endef
+
+define Package/idevicerestore/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/idevicerestore $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,idevicerestore))