aboutsummaryrefslogtreecommitdiff
path: root/utils/i2c-tools/Makefile
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-01 02:09:24 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-01 02:09:24 +0800
commit92e1ce5c8e28f1ee0c0515fbd7745ef301cf7d36 (patch)
tree5998a53e0b7322848744fa76f59f547b8b1d77fb /utils/i2c-tools/Makefile
parent2fae7ce7def8e50949b505b126b53d10ef070dcc (diff)
i2c-tools: Remove Python 2 SMBus bindings package
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'utils/i2c-tools/Makefile')
-rw-r--r--utils/i2c-tools/Makefile22
1 files changed, 1 insertions, 21 deletions
diff --git a/utils/i2c-tools/Makefile b/utils/i2c-tools/Makefile
index 58c5ff86d..388006360 100644
--- a/utils/i2c-tools/Makefile
+++ b/utils/i2c-tools/Makefile
@@ -23,7 +23,6 @@ PKG_BUILD_PARALLEL:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-i2c-tools-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
-include ../../lang/python/python-package.mk
include ../../lang/python/python3-package.mk
PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xJf $(DL_DIR)/$(PKG_SOURCE)
@@ -50,23 +49,13 @@ define Package/i2c-tools
VARIANT:=bin
endef
-define Package/python-smbus
- $(call Package/i2c/Default)
- SUBMENU:=Python
- SECTION:=lang
- CATEGORY:=Languages
- TITLE:=Python bindings for the SMBUS
- DEPENDS:=+PACKAGE_python-smbus:libi2c +PACKAGE_python-smbus:python-light
- VARIANT:=python
-endef
-
define Package/python3-smbus
$(call Package/i2c/Default)
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
TITLE:=Python bindings for the SMBUS
- DEPENDS:=+PACKAGE_python3-smbus:libi2c +PACKAGE_python3-smbus:python3-light
+ DEPENDS:=+libi2c +python3-light
VARIANT:=python3
endef
@@ -79,10 +68,6 @@ define Package/i2c-tools/description
were originally part of the lm-sensors package.
endef
-define Package/python-smbus/description
- This package contain the python bindings for Linux SMBus access through i2c-dev.
-endef
-
define Package/python3-smbus/description
This package contain the Python3 bindings for Linux SMBus access through i2c-dev.
endef
@@ -106,10 +91,7 @@ endef
endif # ifeq
-PYTHON_PKG_SETUP_ARGS:=
PYTHON3_PKG_SETUP_ARGS:=
-
-PYTHON_PKG_SETUP_DIR:=py-smbus
PYTHON3_PKG_SETUP_DIR:=py-smbus
define Package/libi2c/install
@@ -128,7 +110,5 @@ endef
$(eval $(call BuildPackage,libi2c))
$(eval $(call BuildPackage,i2c-tools))
-$(eval $(call PyPackage,python-smbus))
-$(eval $(call BuildPackage,python-smbus))
$(eval $(call Py3Package,python3-smbus))
$(eval $(call BuildPackage,python3-smbus))