aboutsummaryrefslogtreecommitdiff
path: root/utils/i2c-tools/Makefile
diff options
context:
space:
mode:
authorPaulo Costa <paulo.costa@geofusion.com.br>2016-08-16 23:49:06 -0300
committerPaulo Costa <me@paulo.costa.nom.br>2016-11-02 10:46:42 -0200
commit581ec01afa0175e4b19e5b98e9a3747fb1a6ccb6 (patch)
treed04fb70a2cebeeffdb796fd5e0a7cb1515a28527 /utils/i2c-tools/Makefile
parent2c5d49ab4753cb66224d09afd41df29476b52e23 (diff)
i2c-tools: Added python3-smbus package
This only replicates the existing python-smbus package into Python 3 Signed-off-by: Paulo Costa <me@paulo.costa.nom.br>
Diffstat (limited to 'utils/i2c-tools/Makefile')
-rw-r--r--utils/i2c-tools/Makefile32
1 files changed, 31 insertions, 1 deletions
diff --git a/utils/i2c-tools/Makefile b/utils/i2c-tools/Makefile
index c66c80ea8..4fb9b50f5 100644
--- a/utils/i2c-tools/Makefile
+++ b/utils/i2c-tools/Makefile
@@ -26,6 +26,7 @@ PKG_LICENSE_FILES:=COPYING
include $(INCLUDE_DIR)/package.mk
$(call include_mk, python-package.mk)
+$(call include_mk, python3-package.mk)
define Package/i2c/Default
URL:=http://lm-sensors.org/wiki/I2CTools
@@ -48,6 +49,15 @@ define Package/python-smbus
DEPENDS:=+python-light
endef
+define Package/python3-smbus
+ $(call Package/i2c/Default)
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Python bindings for the SMBUS
+ DEPENDS:=+python3-light
+endef
+
define Package/i2c-tools/description
This package contains an heterogeneous set of I2C tools for Linux. These tools
were originally part of the lm-sensors package.
@@ -57,6 +67,10 @@ define Package/python-smbus/description
This package contain the python bindings for Linux SMBus access through i2c-dev.
endef
+define Package/python3-smbus/description
+ This package contain the python bindings for Linux SMBus access through i2c-dev.
+endef
+
TARGET_CPPFLAGS += -I$(PKG_BUILD_DIR)/include
ifdef CONFIG_PACKAGE_python-smbus
@@ -68,6 +82,15 @@ ifdef CONFIG_PACKAGE_python-smbus
endef
endif
+ifdef CONFIG_PACKAGE_python3-smbus
+ define Build/Compile/python3-smbus
+ $(if $(Build/Compile/Py3Mod),,@echo Python3 packaging code not found.; false)
+ $(call Build/Compile/Py3Mod,./py-smbus/, \
+ install --prefix="$(PKG_INSTALL_DIR)/usr", \
+ )
+ endef
+endif
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
LINUX="$(LINUX_DIR)" \
@@ -76,6 +99,7 @@ define Build/Compile
LDFLAGS="$(TARGET_LDFLAGS)" \
CFLAGS="$(TARGET_CFLAGS)"
$(Build/Compile/python-smbus)
+ $(Build/Compile/python3-smbus)
endef
define Package/i2c-tools/install
@@ -87,9 +111,15 @@ define Package/i2c-tools/install
endef
define PyPackage/python-smbus/filespec
-+|$(PYTHON_PKG_DIR)/smbus.so
++|$(PYTHON_PKG_DIR)
+endef
+
+define PyPackage/python3-smbus/filespec
++|$(PYTHON3_PKG_DIR)
endef
$(eval $(call BuildPackage,i2c-tools))
$(eval $(call PyPackage,python-smbus))
$(eval $(call BuildPackage,python-smbus))
+$(eval $(call PyPackage,python3-smbus))
+$(eval $(call BuildPackage,python3-smbus))