aboutsummaryrefslogtreecommitdiff
path: root/utils/hwdata/Makefile
diff options
context:
space:
mode:
authorGeorgi Valkov <gvalkov@abv.bg>2021-01-30 14:23:48 +0200
committerGeorgi Valkov <gvalkov@abv.bg>2021-02-01 10:17:23 +0200
commit884d3fa69100e0387cfc67402077f4f716fc7fcd (patch)
tree18f4e0cc2d1e0b2b47d435cf8c008fd936f7f6c6 /utils/hwdata/Makefile
parent9133e79ccb864bb2d92a386fc104258dc6c28de0 (diff)
hwdata: fix build error on macOS
The install command on macOS does not support the -T flag. As suggested by Rosen Penev, this package does not compile anything, so the contents can be installed directly. Signed-off-by: Georgi Valkov <gvalkov@abv.bg>
Diffstat (limited to 'utils/hwdata/Makefile')
-rw-r--r--utils/hwdata/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/utils/hwdata/Makefile b/utils/hwdata/Makefile
index fd0bc14ad..0de3dbf78 100644
--- a/utils/hwdata/Makefile
+++ b/utils/hwdata/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hwdata
PKG_VERSION:=0.343
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/vcrhonek/hwdata/tar.gz/v$(PKG_VERSION)?
@@ -17,9 +17,6 @@ PKG_MAINTAINER:=
PKG_LICENSE:=GPL-2.0-or-later XFree86-1.0
PKG_LICENSE_FILES:=LICENSE
-PKG_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
-
include $(INCLUDE_DIR)/package.mk
define Package/pciids
@@ -38,12 +35,12 @@ endef
define Package/pciids/install
$(INSTALL_DIR) $(1)/usr/share/hwdata
- $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/hwdata/pci.ids $(1)/usr/share/hwdata
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/pci.ids $(1)/usr/share/hwdata
endef
define Package/usbids/install
$(INSTALL_DIR) $(1)/usr/share/hwdata
- $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/hwdata/usb.ids $(1)/usr/share/hwdata
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/usb.ids $(1)/usr/share/hwdata
endef
$(eval $(call BuildPackage,pciids))