aboutsummaryrefslogtreecommitdiff
path: root/utils/hplip
diff options
context:
space:
mode:
authorMichal Vasilek <michal.vasilek@nic.cz>2021-09-02 15:59:15 +0200
committerMichal Vasilek <michal.vasilek@nic.cz>2021-09-03 10:47:38 +0200
commit85fbf6cf4d4134f9679b4ac510d966b00891a503 (patch)
tree7e568454e2fd63ec777a7cf175821626df9399f9 /utils/hplip
parent1f132a184b60b3fc5e263a88d4b6559cd3adf819 (diff)
hplip: add a patch to respect CFLAGS
* fixes build with PIE Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
Diffstat (limited to 'utils/hplip')
-rw-r--r--utils/hplip/patches/070-respect-cflags.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/utils/hplip/patches/070-respect-cflags.patch b/utils/hplip/patches/070-respect-cflags.patch
new file mode 100644
index 000000000..c1f7c7957
--- /dev/null
+++ b/utils/hplip/patches/070-respect-cflags.patch
@@ -0,0 +1,29 @@
+--- a/configure.in
++++ b/configure.in
+@@ -632,14 +632,14 @@ if test "$class_driver" = "no" && test "
+ fi
+ fi
+
+-SAVE_CPPFLAGS="$CPPFLAGS"
++SAVE_CFLAGS="$CFLAGS"
+ CFLAGS=`python-config --includes`
+-if [ $? -eq 0 ]
++if test $? -eq 0
+ then
+ echo $FLAGS
+ else
+ CFLAGS=`python3-config --includes`
+- if [ $? -eq 0 ]
++ if test $? -eq 0
+ then
+ echo $FLAGS
+ fi
+@@ -659,7 +659,7 @@ if test "$class_driver" = "no" && test "
+ AS_IF([test "x$FOUND_HEADER" != "xyes"],
+ [AC_MSG_ERROR([cannot find python-devel support], 6)])
+ fi
+-CFLAGS="$save_CFLAGS"
++CFLAGS="$SAVE_CFLAGS"
+
+ if test "$hpijs_only_build" = "no" && test "$scan_build" = "yes" && test "$hpcups_only_build" = "no"; then
+ AC_CHECK_LIB([sane], [sane_open], [LIBS="$LIBS"], [AC_MSG_ERROR([cannot find sane-backends-devel support (or --disable-scan-build)], 12)])