aboutsummaryrefslogtreecommitdiff
path: root/utils/hdparm
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-01-21 21:34:37 -0800
committerRosen Penev <rosenp@gmail.com>2019-01-21 21:38:57 -0800
commitcb6e9c6f2134f681c0870641dfc63de0a2debd95 (patch)
tree610f55bf7949c8789d0fcc407273f51d5a7b4482 /utils/hdparm
parentc0d468452861ca1026e32272dd02b5bcfef5c755 (diff)
hdparm: Fix LDFLAGS
Based on debian patch. LDFLAGS were not being passed, which caused relro to not be applies. Also made stock CFLAGS optional. -fkeep-inline was keeping sizes high. Removed PKG_NO_MIPS16 as the original problem seems to be gone. Size from 54338 to 50761 Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/hdparm')
-rw-r--r--utils/hdparm/Makefile3
-rw-r--r--utils/hdparm/patches/010-ldflags.patch13
2 files changed, 13 insertions, 3 deletions
diff --git a/utils/hdparm/Makefile b/utils/hdparm/Makefile
index e095af4ad..78b7b9906 100644
--- a/utils/hdparm/Makefile
+++ b/utils/hdparm/Makefile
@@ -10,7 +10,6 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hdparm
PKG_VERSION:=9.58
PKG_RELEASE:=1
-PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -21,8 +20,6 @@ PKG_LICENSE:=BSD-Style Open Source License
include $(INCLUDE_DIR)/package.mk
-TARGET_CFLAGS+=-D_GNU_SOURCE
-
define Package/hdparm
SECTION:=utils
CATEGORY:=Utilities
diff --git a/utils/hdparm/patches/010-ldflags.patch b/utils/hdparm/patches/010-ldflags.patch
new file mode 100644
index 000000000..e4778748d
--- /dev/null
+++ b/utils/hdparm/patches/010-ldflags.patch
@@ -0,0 +1,13 @@
+--- a/Makefile
++++ b/Makefile
+@@ -13,9 +13,8 @@ oldmandir = $(manprefix)/man
+ CC ?= gcc
+ STRIP ?= strip
+
+-CFLAGS := -O2 -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs $(CFLAGS)
++CFLAGS ?= -O2 -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs $(CFLAGS)
+
+-LDFLAGS = -s
+ #LDFLAGS = -s -static
+ INSTALL = install
+ INSTALL_DATA = $(INSTALL) -m 644