aboutsummaryrefslogtreecommitdiff
path: root/utils/hashdeep/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-02-22 20:58:58 -0800
committerRosen Penev <rosenp@gmail.com>2021-03-05 15:07:46 -0800
commit39bc254663c6a5d54ff959366aba28f6ab9d7c4c (patch)
treec45c55e5b22363e7deb6693808bdcc99cfaab46a /utils/hashdeep/Makefile
parentf2d7f216a4ec25554674348d21bbafc5308a6f2f (diff)
treewide: remove uClibc++ support
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/hashdeep/Makefile')
-rw-r--r--utils/hashdeep/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/utils/hashdeep/Makefile b/utils/hashdeep/Makefile
index f697e08e2..673d389c0 100644
--- a/utils/hashdeep/Makefile
+++ b/utils/hashdeep/Makefile
@@ -2,19 +2,20 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hashdeep
PKG_VERSION:=4.4
-PKG_RELEASE:=1
-PKG_MAINTAINER=Tobe Deprez <trldp@outlook.com>
-PKG_LICENSE:=NLPL
-PKG_LICENSE_FILES:=COPYING
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/jessek/hashdeep/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=ad78d42142f9a74fe8ec0c61bc78d6588a528cbb9aede9440f50b6ff477f3a7f
+PKG_MAINTAINER:=Tobe Deprez <trldp@outlook.com>
+PKG_LICENSE:=NLPL
+PKG_LICENSE_FILES:=COPYING
+
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
-include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
define Package/hashdeep
@@ -22,7 +23,7 @@ define Package/hashdeep
CATEGORY:=Utilities
TITLE:=Recursively compute hashsums or piecewise hashings
URL:=http://md5deep.sourceforge.net/
- DEPENDS:=$(CXX_DEPENDS)
+ DEPENDS:=+libstdcpp
endef
define Package/hashdeep/description