aboutsummaryrefslogtreecommitdiff
path: root/utils/haserl
diff options
context:
space:
mode:
authorIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-20 16:02:15 -0800
committerIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-20 16:02:15 -0800
commit5d8d4fbbcb5c5de9370711c19bb3510210989a98 (patch)
treed0754921833f413b7eb93fb6bb1b1c8a22fb0498 /utils/haserl
parentd651082447b4392399a40ea1ae11d0bce4bfe83a (diff)
treewide: Run refresh on all packages
The crude loop I wrote to come up with this changeset: find -L package/feeds/packages/ -name patches | \ sed 's/patches$/refresh/' | sort | xargs make Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
Diffstat (limited to 'utils/haserl')
-rw-r--r--utils/haserl/patches/100-replace-lua2c-with-sed.patch4
-rw-r--r--utils/haserl/patches/101-adjust-script-size.patch6
2 files changed, 4 insertions, 6 deletions
diff --git a/utils/haserl/patches/100-replace-lua2c-with-sed.patch b/utils/haserl/patches/100-replace-lua2c-with-sed.patch
index 4626a0289..622995edd 100644
--- a/utils/haserl/patches/100-replace-lua2c-with-sed.patch
+++ b/utils/haserl/patches/100-replace-lua2c-with-sed.patch
@@ -1,5 +1,3 @@
-diff --git a/src/Makefile.in b/src/Makefile.in
-index 31d45f7..d249f67 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -86,7 +86,6 @@ POST_INSTALL = :
@@ -40,7 +38,7 @@ index 31d45f7..d249f67 100644
# Not strictly required, but we explicitly do not distribute the generated inc file
nodist_haserl_SOURCES = haserl_lualib.inc
-@@ -396,10 +392,6 @@ haserl$(EXEEXT): $(haserl_OBJECTS) $(haserl_DEPENDENCIES) $(EXTRA_haserl_DEPENDE
+@@ -396,10 +392,6 @@ haserl$(EXEEXT): $(haserl_OBJECTS) $(has
@rm -f haserl$(EXEEXT)
$(AM_V_CCLD)$(haserl_LINK) $(haserl_OBJECTS) $(haserl_LDADD) $(LIBS)
diff --git a/utils/haserl/patches/101-adjust-script-size.patch b/utils/haserl/patches/101-adjust-script-size.patch
index a4b7d9a4d..1c4da2531 100644
--- a/utils/haserl/patches/101-adjust-script-size.patch
+++ b/utils/haserl/patches/101-adjust-script-size.patch
@@ -1,6 +1,6 @@
---- a/src/h_lua_common.c 2013-09-20 23:35:19.000000000 +0300
-+++ b/src/h_lua_common.c 2014-05-03 19:27:43.000000000 +0300
-@@ -79,7 +79,7 @@
+--- a/src/h_lua_common.c
++++ b/src/h_lua_common.c
+@@ -79,7 +79,7 @@ lua_common_setup (char *shell, list_t *
/* and load our haserl library */
if (luaL_loadbuffer