aboutsummaryrefslogtreecommitdiff
path: root/utils/haserl
diff options
context:
space:
mode:
authorMaxim Storchak <m.storchak@gmail.com>2015-02-28 12:04:51 +0200
committerMaxim Storchak <m.storchak@gmail.com>2015-02-28 12:04:51 +0200
commit5b90cf85de58f8d2267d653b79a1078ccf993692 (patch)
tree1133db00e189a65bb474fb5c7cf83ff58bbee6ad /utils/haserl
parent137744a742d716fc7975dbc35ab04891a948f4cd (diff)
haserl: update to 0.9.34
Signed-off-by: Maxim Storchak <m.storchak@gmail.com>
Diffstat (limited to 'utils/haserl')
-rw-r--r--utils/haserl/Makefile4
-rw-r--r--utils/haserl/patches/100-replace-lua2c-with-sed.patch22
2 files changed, 14 insertions, 12 deletions
diff --git a/utils/haserl/Makefile b/utils/haserl/Makefile
index 90bfd24fd..89cfa4ab5 100644
--- a/utils/haserl/Makefile
+++ b/utils/haserl/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=haserl
-PKG_VERSION:=0.9.33
+PKG_VERSION:=0.9.34
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/haserl
-PKG_MD5SUM:=a9decddb508944d56f71dd2f821e2ec5
+PKG_MD5SUM:=cae2240f25040c7a0a270c35cf7abda4
PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING
diff --git a/utils/haserl/patches/100-replace-lua2c-with-sed.patch b/utils/haserl/patches/100-replace-lua2c-with-sed.patch
index 5b19fc1ec..4626a0289 100644
--- a/utils/haserl/patches/100-replace-lua2c-with-sed.patch
+++ b/utils/haserl/patches/100-replace-lua2c-with-sed.patch
@@ -1,6 +1,8 @@
---- a/src/Makefile.in 2013-09-20 23:52:15.000000000 +0300
-+++ b/src/Makefile.in 2014-05-03 23:06:17.000000000 +0300
-@@ -76,7 +76,6 @@
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 31d45f7..d249f67 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -86,7 +86,6 @@ POST_INSTALL = :
NORMAL_UNINSTALL = :
PRE_UNINSTALL = :
POST_UNINSTALL = :
@@ -8,7 +10,7 @@
@INCLUDE_LUASHELL_TRUE@@USE_LUA_TRUE@am__append_1 = h_lua.c h_lua.h
@INCLUDE_LUACSHELL_TRUE@@USE_LUA_TRUE@am__append_2 = h_luac.c h_luac.h
bin_PROGRAMS = haserl$(EXEEXT)
-@@ -115,9 +114,6 @@
+@@ -124,9 +123,6 @@ am__DEPENDENCIES_1 =
haserl_DEPENDENCIES = $(am__DEPENDENCIES_1)
haserl_LINK = $(CCLD) $(haserl_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
$(LDFLAGS) -o $@
@@ -18,7 +20,7 @@
AM_V_P = $(am__v_P_@AM_V@)
am__v_P_ = $(am__v_P_@AM_DEFAULT_V@)
am__v_P_0 = false
-@@ -150,8 +146,8 @@
+@@ -159,8 +155,8 @@ AM_V_CCLD = $(am__v_CCLD_@AM_V@)
am__v_CCLD_ = $(am__v_CCLD_@AM_DEFAULT_V@)
am__v_CCLD_0 = @echo " CCLD " $@;
am__v_CCLD_1 =
@@ -29,7 +31,7 @@
am__can_run_installinfo = \
case $$AM_UPDATE_INFO_DIR in \
n|no|NO) false;; \
-@@ -273,7 +269,7 @@
+@@ -284,7 +280,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
@@ -38,7 +40,7 @@
# Not strictly required, but we explicitly do not distribute the generated inc file
nodist_haserl_SOURCES = haserl_lualib.inc
-@@ -386,10 +382,6 @@
+@@ -396,10 +392,6 @@ haserl$(EXEEXT): $(haserl_OBJECTS) $(haserl_DEPENDENCIES) $(EXTRA_haserl_DEPENDE
@rm -f haserl$(EXEEXT)
$(AM_V_CCLD)$(haserl_LINK) $(haserl_OBJECTS) $(haserl_LDADD) $(LIBS)
@@ -49,7 +51,7 @@
mostlyclean-compile:
-rm -f *.$(OBJEXT)
-@@ -406,7 +398,6 @@
+@@ -416,7 +408,6 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/haserl-haserl.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/haserl-rfc2388.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/haserl-sliding_buffer.Po@am__quote@
@@ -57,8 +59,8 @@
.c.o:
@am__fastdepCC_TRUE@ $(AM_V_CC)$(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
-@@ -758,17 +749,13 @@
- tags tags-am uninstall uninstall-am uninstall-binPROGRAMS
+@@ -770,17 +761,13 @@ uninstall-am: uninstall-binPROGRAMS
+ .PRECIOUS: Makefile
-# lua2c_LIBS ?= -llua -ldl -lm