aboutsummaryrefslogtreecommitdiff
path: root/utils/hamlib
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-06-15 09:40:00 +0200
committerSteven Barth <steven@midlink.org>2014-06-15 09:42:08 +0200
commit9322b39614f11496b9e925c644bdb16274a7443a (patch)
tree76f4fbec9b8727b3fa92de9853bceebb2cbfea8d /utils/hamlib
parent362dde6aff641bc26d8865bed8a7455f0b75f565 (diff)
hamlib: avoid build failures with spurious libraries
* always use libusb >= 1.0 (avoid pulling libusb-compat) * never use libxml2 Signed-off-by: Steven Barth <steven@midlink.org>
Diffstat (limited to 'utils/hamlib')
-rw-r--r--utils/hamlib/Makefile2
-rw-r--r--utils/hamlib/patches/100-override-autoconf-detection.patch30
2 files changed, 31 insertions, 1 deletions
diff --git a/utils/hamlib/Makefile b/utils/hamlib/Makefile
index 40909ea7e..f43566386 100644
--- a/utils/hamlib/Makefile
+++ b/utils/hamlib/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hamlib
PKG_VERSION:=1.2.15.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MD5SUM:=3cad8987e995a00e5e9d360e2be0eb43
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/utils/hamlib/patches/100-override-autoconf-detection.patch b/utils/hamlib/patches/100-override-autoconf-detection.patch
new file mode 100644
index 000000000..284cc3b4e
--- /dev/null
+++ b/utils/hamlib/patches/100-override-autoconf-detection.patch
@@ -0,0 +1,30 @@
+Index: hamlib-1.2.15.3/configure.ac
+===================================================================
+--- hamlib-1.2.15.3.orig/configure.ac 2012-11-01 22:27:27.000000000 +0100
++++ hamlib-1.2.15.3/configure.ac 2014-06-15 09:34:25.557966205 +0200
+@@ -234,12 +234,12 @@
+ "You need a C99 compliant C compiler that supports struct/array intializers."
+ "Have you considered GCC lately?.")]);
+
+-dnl libxml2 required rigmem xml support
+-PKG_CHECK_MODULES([LIBXML2], [libxml-2.0],
+- [AC_DEFINE(HAVE_XML2,[1],[Define if libxml2 is available])],
+- [AC_MSG_WARN([libxml-2.0 pkg-config not found, XML support will be disabled])])
++#dnl libxml2 required rigmem xml support
++#PKG_CHECK_MODULES([LIBXML2], [libxml-2.0],
++# [AC_DEFINE(HAVE_XML2,[1],[Define if libxml2 is available])],
++# [AC_MSG_WARN([libxml-2.0 pkg-config not found, XML support will be disabled])])
+ AC_SUBST(LIBXML2_LIBS)
+ AC_SUBST(LIBXML2_CFLAGS)
+
+ dnl Check if libgd-dev is installed, so we can enable rigmatrix
+
+@@ -406,7 +406,7 @@
+ AM_CONDITIONAL(HAVE_USRP, test x"${cf_with_usrp}" = "xyes")
+
+
+-PKG_CHECK_MODULES(LIBUSB, libusb >= 0.1, ,
++PKG_CHECK_MODULES(LIBUSB, libusb >= 1.0, ,
+ [AC_MSG_WARN([libusb pkg-config not found, USB backends will be disabled])])
+ CFLAGS="${CFLAGS} ${LIBUSB_CFLAGS}"
+ CXXFLAGS="${CXXFLAGS} ${LIBUSB_CFLAGS}"