aboutsummaryrefslogtreecommitdiff
path: root/utils/hamlib/Makefile
diff options
context:
space:
mode:
authorJesper Henriksen <mail-openwrt@jesper.io>2023-02-12 14:29:39 +0100
committerJesper Henriksen <mail-openwrt@jesper.io>2023-02-12 14:30:36 +0100
commit45f6a8ddd2c7aaf125e596f3d9329bb2c4717d95 (patch)
tree75c2ed3640dcf5128bfda63c22d4e908c1f81a99 /utils/hamlib/Makefile
parentb064f6b5dbc0cc44e891caafb5f612c75d9d992b (diff)
hamlib: Added init and config files
Signed-off-by: Jesper Henriksen <mail-openwrt@jesper.io>
Diffstat (limited to 'utils/hamlib/Makefile')
-rw-r--r--utils/hamlib/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/utils/hamlib/Makefile b/utils/hamlib/Makefile
index 91ef75466..553aa57b7 100644
--- a/utils/hamlib/Makefile
+++ b/utils/hamlib/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hamlib
PKG_VERSION:=4.5.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/hamlib
@@ -43,6 +43,10 @@ define Package/hamlib
DEPENDS:=+libhamlib
endef
+define Package/hamlib/conffiles
+/etc/config/rigctld
+endef
+
define Package/hamlib/description
$(call Package/hamlib/Default/description)
@@ -90,6 +94,12 @@ CONFIGURE_VARS+= \
define Package/hamlib/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/{rig,rot}* $(1)/usr/bin/
+
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/rigctld.init $(1)/etc/init.d/rigctld
+
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_CONF) ./files/rigctld.conf $(1)/etc/config/rigctld
endef
define Package/libhamlib/install