aboutsummaryrefslogtreecommitdiff
path: root/utils/grep
diff options
context:
space:
mode:
authorMichal Vasilek <michal.vasilek@nic.cz>2021-08-24 15:30:25 +0200
committerMichal Vasilek <michal.vasilek@nic.cz>2021-08-24 15:40:28 +0200
commit8bf1ab3a29cdb4dff60723700359e2a0de7bf774 (patch)
tree5edeb91db294547126dafdb16fe3e810af300c60 /utils/grep
parentd96ae81d241e0f42789a70029ab5636ef1d64231 (diff)
grep: update to 3.7
Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
Diffstat (limited to 'utils/grep')
-rw-r--r--utils/grep/Makefile4
-rw-r--r--utils/grep/patches/ppc-musl.patch15
2 files changed, 17 insertions, 2 deletions
diff --git a/utils/grep/Makefile b/utils/grep/Makefile
index 38cb1ea88..2ec599095 100644
--- a/utils/grep/Makefile
+++ b/utils/grep/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=grep
-PKG_VERSION:=3.6
+PKG_VERSION:=3.7
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/grep
-PKG_HASH:=667e15e8afe189e93f9f21a7cd3a7b3f776202f417330b248c2ad4f997d9373e
+PKG_HASH:=5c10da312460aec721984d5d83246d24520ec438dd48d7ab5a05dbc0d6d6823c
PKG_MAINTAINER:=Julen Landa Alustiza <julen@zokormazo.info>
PKG_LICENSE:=GPL-3.0-or-later
diff --git a/utils/grep/patches/ppc-musl.patch b/utils/grep/patches/ppc-musl.patch
new file mode 100644
index 000000000..45c79eb04
--- /dev/null
+++ b/utils/grep/patches/ppc-musl.patch
@@ -0,0 +1,15 @@
+https://github.com/void-linux/void-packages/commit/0d9556b8593d6e67027fb1c83d176b7f899547e5
+--- a/lib/sigsegv.c
++++ b/lib/sigsegv.c
+@@ -221,8 +221,10 @@ int libsigsegv_version = LIBSIGSEGV_VERS
+ /* both should be equivalent */
+ # if 0
+ # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
+-# else
++# elif defined(__GLIBC__)
+ # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
++# else
++# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gregs[1]
+ # endif
+ # endif
+