aboutsummaryrefslogtreecommitdiff
path: root/utils/grep
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-09-10 08:20:17 +0200
committerRosen Penev <rosenp@gmail.com>2022-09-17 12:56:09 -0700
commit16d57bbfb6fdb41027e89bc2cee46452473c2ef8 (patch)
tree8dbcd8f56261dae26d6f819ae911d828dc31874f /utils/grep
parentfbcedc003e8e1d7602acdd91ee744076a091cc90 (diff)
grep: update to 3.8
Manually refresh: - ppc-musl.patch Release Notes: https://lists.gnu.org/archive/html/info-gnu/2022-09/msg00001.html Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'utils/grep')
-rw-r--r--utils/grep/Makefile6
-rw-r--r--utils/grep/patches/ppc-musl.patch18
2 files changed, 12 insertions, 12 deletions
diff --git a/utils/grep/Makefile b/utils/grep/Makefile
index 55190b1b8..6096adaf3 100644
--- a/utils/grep/Makefile
+++ b/utils/grep/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=grep
-PKG_VERSION:=3.7
-PKG_RELEASE:=2
+PKG_VERSION:=3.8
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/grep
-PKG_HASH:=5c10da312460aec721984d5d83246d24520ec438dd48d7ab5a05dbc0d6d6823c
+PKG_HASH:=498d7cc1b4fb081904d87343febb73475cf771e424fb7e6141aff66013abc382
PKG_MAINTAINER:=Julen Landa Alustiza <julen@zokormazo.info>
PKG_LICENSE:=GPL-3.0-or-later
diff --git a/utils/grep/patches/ppc-musl.patch b/utils/grep/patches/ppc-musl.patch
index 45c79eb04..aeb026689 100644
--- a/utils/grep/patches/ppc-musl.patch
+++ b/utils/grep/patches/ppc-musl.patch
@@ -1,15 +1,15 @@
https://github.com/void-linux/void-packages/commit/0d9556b8593d6e67027fb1c83d176b7f899547e5
--- a/lib/sigsegv.c
+++ b/lib/sigsegv.c
-@@ -221,8 +221,10 @@ int libsigsegv_version = LIBSIGSEGV_VERS
- /* both should be equivalent */
- # if 0
- # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
--# else
-+# elif defined(__GLIBC__)
- # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
-+# else
+@@ -246,8 +246,10 @@ int libsigsegv_version = LIBSIGSEGV_VERS
+ /* Because of the union, both definitions should be equivalent. */
+ # if 0
+ # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
+-# else
++# elif defined(__GLIBC__)
+ # define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
++# else
+# define SIGSEGV_FAULT_STACKPOINTER ((ucontext_t *) ucp)->uc_mcontext.gregs[1]
+ # endif
# endif
# endif
-