aboutsummaryrefslogtreecommitdiff
path: root/utils/gpsd/Makefile
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-01-17 04:42:46 +0800
committerJeffery To <jeffery.to@gmail.com>2020-01-17 04:42:46 +0800
commita29905c42b2af258cede2c647dc3309c8eb6a379 (patch)
tree38b402d4ee6de71015976740618420406a6d79b0 /utils/gpsd/Makefile
parent1fbdc4d1a419242cbcec317d1eb76889c7804f4f (diff)
gpsd: Update to 3.20, add/refresh patches
New patches (both for SConstruct): * Do not import from distutils. Since Python support/modules are not built, there is no need to import from distutils. (Importing from distutils may prevent the package from being built on systems without a full distutils module, e.g. Debian with python3-minimal.) I have added back the import in places where it may be helpful to have, if scons is run manually. Fixes #10993. * Do not check the size of time_t. The way this is done is to compile and run a test program; this fails when cross-compiling[1]. This doesn't appear to affect any functionality (other than missing a compile-time warning that things will fail in 2038 if time_t is too small). [1]: https://gitlab.com/gpsd/gpsd/issues/48 Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'utils/gpsd/Makefile')
-rw-r--r--utils/gpsd/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/utils/gpsd/Makefile b/utils/gpsd/Makefile
index a6756659d..086b1fcdf 100644
--- a/utils/gpsd/Makefile
+++ b/utils/gpsd/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gpsd
-PKG_VERSION:=3.19
-PKG_RELEASE:=2
+PKG_VERSION:=3.20
+PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
-PKG_HASH:=27dd24d45b2ac69baab7933da2bf6ae5fb0be90130f67e753c110a3477155f39
+PKG_HASH:=3998a5cbb728e97f896f46c3c83301b1e6c5d859393e58c2fad8c5426774d571
PKG_MAINTAINER:=Pushpal Sidhu <psidhu.devel@gmail.com>
PKG_LICENSE:=BSD-3-Clause