aboutsummaryrefslogtreecommitdiff
path: root/utils/gnupg/Makefile
diff options
context:
space:
mode:
authorHeinrich Schuchardt <xypron.glpk@gmx.de>2016-02-10 18:27:08 +0100
committerHeinrich Schuchardt <xypron.glpk@gmx.de>2016-02-10 19:19:56 +0100
commitd708a54870e1290a614783953d43edbf784086d4 (patch)
treed0d3c625b16d52732c08ea54f31a91e7285d9c17 /utils/gnupg/Makefile
parent351f42ca54c505d11d90370bf3834b7d14d99124 (diff)
gnupg: fix dependency error concerning libcurl
libcurl is added as dependency for gnupg-util to avoid a dependency error. The following invalid configuration options are removed: --disable-ftp --enable-fake-curl Fixes: 0a61d56eb3ab ("utils/gnupg: add new package gnupg-utils") Reported-by: Hannu Nyman <hannu.nyman@iki.fi> Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
Diffstat (limited to 'utils/gnupg/Makefile')
-rw-r--r--utils/gnupg/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/utils/gnupg/Makefile b/utils/gnupg/Makefile
index 65209bb98..193a82040 100644
--- a/utils/gnupg/Makefile
+++ b/utils/gnupg/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gnupg
PKG_VERSION:=1.4.20
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/gnupg \
@@ -39,7 +39,7 @@ endef
define Package/gnupg-utils
$(call Package/gnupg/Default)
- DEPENDS:=gnupg
+ DEPENDS:=gnupg +libcurl
TITLE:=Key management utilities for GnuPG
endef
@@ -67,9 +67,7 @@ CONFIGURE_ARGS += \
--disable-bzip2 \
--disable-ldap \
--disable-finger \
- --disable-ftp \
--disable-dns-srv \
- --enable-fake-curl \
--disable-regex \
MAKE_FLAGS += \