aboutsummaryrefslogtreecommitdiff
path: root/utils/gddrescue
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-10-12 17:52:27 -0700
committerRosen Penev <rosenp@gmail.com>2019-10-12 17:52:27 -0700
commitcb6ec2061bf6e55cfaa84c5734087ee40317a917 (patch)
treea6e2568a611e0a54c2e975c17db82fe275126184 /utils/gddrescue
parentc201c68072a65f8bb9f608b5b28e73bb1af67b11 (diff)
gddrescue: Remove uClibc++ patch
A solution was applied to uClibc++, where the bug actually is. Fixed license information. Small cleanups. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/gddrescue')
-rw-r--r--utils/gddrescue/Makefile6
-rw-r--r--utils/gddrescue/patches/010-fix-uclibcxx.patch102
2 files changed, 3 insertions, 105 deletions
diff --git a/utils/gddrescue/Makefile b/utils/gddrescue/Makefile
index 192c26500..c5de5ebb7 100644
--- a/utils/gddrescue/Makefile
+++ b/utils/gddrescue/Makefile
@@ -6,14 +6,14 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gddrescue
PKG_VERSION:=1.23
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.xz
PKG_SOURCE_URL:=http://http.debian.net/debian/pool/main/g/$(PKG_NAME)
PKG_HASH:=5831d7e24070bc700d8f22deaeec56af1149392ce30ae67254096eaf8c9169ab
-PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
-PKG_LICENSE:=GPL-2.0
+PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
+PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=LICENSE
PKG_INSTALL:=1
diff --git a/utils/gddrescue/patches/010-fix-uclibcxx.patch b/utils/gddrescue/patches/010-fix-uclibcxx.patch
deleted file mode 100644
index 66e8e7671..000000000
--- a/utils/gddrescue/patches/010-fix-uclibcxx.patch
+++ /dev/null
@@ -1,102 +0,0 @@
---- a/fillbook.cc
-+++ b/fillbook.cc
-@@ -31,6 +31,9 @@
- #include "block.h"
- #include "mapbook.h"
-
-+#ifdef __UCLIBCXX_MAJOR__
-+#undef fputc
-+#endif
-
- // Return values: 1 write error, 0 OK.
- //
---- a/genbook.cc
-+++ b/genbook.cc
-@@ -31,6 +31,9 @@
- #include "block.h"
- #include "mapbook.h"
-
-+#ifdef __UCLIBCXX_MAJOR__
-+#undef fputc
-+#endif
-
- const char * format_time( const long t, const bool low_prec )
- {
---- a/loggers.cc
-+++ b/loggers.cc
-@@ -25,6 +25,9 @@
- #include "block.h"
- #include "loggers.h"
-
-+#ifdef __UCLIBCXX_MAJOR__
-+#undef fputc
-+#endif
-
- namespace {
-
---- a/main.cc
-+++ b/main.cc
-@@ -46,6 +46,11 @@
- #include "non_posix.h"
- #include "rescuebook.h"
-
-+#ifdef __UCLIBCXX_MAJOR__
-+#undef fgetc
-+#undef fputc
-+#endif
-+
- #ifndef O_BINARY
- #define O_BINARY 0
- #endif
---- a/main_common.cc
-+++ b/main_common.cc
-@@ -15,6 +15,10 @@
- along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-+#ifdef __UCLIBCXX_MAJOR__
-+#undef fputc
-+#endif
-+
- int verbosity = 0;
-
- namespace {
---- a/mapbook.cc
-+++ b/mapbook.cc
-@@ -32,6 +32,10 @@
- #include "block.h"
- #include "mapbook.h"
-
-+#ifdef __UCLIBCXX_MAJOR__
-+#undef fgetc
-+#undef fputc
-+#endif
-
- namespace {
-
---- a/mapfile.cc
-+++ b/mapfile.cc
-@@ -29,6 +29,11 @@
-
- #include "block.h"
-
-+#ifdef __UCLIBCXX_MAJOR__
-+#undef fgetc
-+#undef ferror
-+#undef feof
-+#endif
-
- namespace {
-
---- a/rescuebook.cc
-+++ b/rescuebook.cc
-@@ -36,6 +36,9 @@
- #include "mapbook.h"
- #include "rescuebook.h"
-
-+#ifdef __UCLIBCXX_MAJOR__
-+#undef fputc
-+#endif
-
- namespace {
-