aboutsummaryrefslogtreecommitdiff
path: root/utils/gammu/patches
diff options
context:
space:
mode:
authoraTanW <villy@sft.ru>2014-12-09 19:32:33 +0300
committeraTanW <villy@sft.ru>2014-12-09 19:32:33 +0300
commitf044f11552a1872de82ca1768a51d634231f4a4a (patch)
treeeafa436e066ae61cc00bc24bef96b63d4f369dab /utils/gammu/patches
parent5118fb228659c1f298bf7ad7fb6f3bf92738342f (diff)
This adds package gammu v 1.33.0 to the build tree
Gammu is a tool for cell phone/modem control, including send/receive SMS, phone directory and other. Signed-off-by: Vitaly Protsko <villy@sft.ru> --- Makefile | 68 +++++++++++++++++++++++++++++++ files/gammurc | 37 ++++++++++++++++ patches/001-iconv-disabling-option.patch | 51 +++++++++++++++++++++++ patches/002-no-fstack-protector.patch | 11 +++++ patches/003-cmake-cross-toolchain.patch | 43 +++++++++++++++++++ patches/010-utils-shell-fix.patch | 16 +++++++ 6 files changed, 226 insertions(+)
Diffstat (limited to 'utils/gammu/patches')
-rw-r--r--utils/gammu/patches/001-iconv-disabling-option.patch51
-rw-r--r--utils/gammu/patches/002-no-fstack-protector.patch11
-rw-r--r--utils/gammu/patches/003-cmake-cross-toolchain.patch43
-rw-r--r--utils/gammu/patches/010-utils-shell-fix.patch16
4 files changed, 121 insertions, 0 deletions
diff --git a/utils/gammu/patches/001-iconv-disabling-option.patch b/utils/gammu/patches/001-iconv-disabling-option.patch
new file mode 100644
index 000000000..91abfe753
--- /dev/null
+++ b/utils/gammu/patches/001-iconv-disabling-option.patch
@@ -0,0 +1,51 @@
+--- a/cmake/FindIconv.cmake
++++ b/cmake/FindIconv.cmake
+@@ -34,9 +34,9 @@ string(REGEX REPLACE "(.*)/include/?" "\
+
+ FIND_LIBRARY(ICONV_LIBRARIES NAMES iconv libiconv c HINTS "${ICONV_INCLUDE_BASE_DIR}/lib" PATHS /opt/local/lib)
+
+-IF(ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
++IF(NOT DISABLE_ICONV AND ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
+ SET(ICONV_FOUND TRUE)
+-ENDIF(ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
++ENDIF(NOT DISABLE_ICONV AND ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
+
+ set(CMAKE_REQUIRED_INCLUDES ${ICONV_INCLUDE_DIR})
+ set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBRARIES})
+--- a/configure
++++ b/configure
+@@ -31,6 +31,7 @@ Usage: ./configure [options]
+ --enable-backup enable backup support
+ --enable-win32 enable mingw crosscomilation
+ --enable-protection enable compile time protections
++--disable-iconv disable iconv support
+ --with-python=<path> path to Python interpreter
+ --without-gnapplet disable installation of gnapplet
+ --without-completion disable installation of bash completion script
+@@ -57,6 +58,7 @@ CMAKE_PROTECTION=
+ CMAKE_PYTHON=
+ CMAKE_GNAP=
+ CMAKE_COMPLETE=
++CMAKE_ICONV=
+
+ # process command line
+ while [ "$#" -gt 0 ] ; do
+@@ -94,6 +96,12 @@ while [ "$#" -gt 0 ] ; do
+ --disable-protection)
+ CMAKE_PROTECTION="-DENABLE_PROTECTION=OFF"
+ ;;
++ --enable-iconv)
++ CMAKE_ICONV="-DDISABLE_ICONV=OFF"
++ ;;
++ --disable-iconv)
++ CMAKE_ICONV="-DDISABLE_ICONV=ON"
++ ;;
+ --enable-debug)
+ CMAKE_DEBUG="-DCMAKE_BUILD_TYPE=Debug"
+ ;;
+@@ -142,4 +150,4 @@ fi
+ cd "$BUILD_DIR"
+
+ # invoke cmake to do configuration
+-cmake $SOURCE_DIR $CMAKE_PREFIX $CMAKE_SHARED $CMAKE_DEBUG $CMAKE_BACKUP $CMAKE_CROSS $CMAKE_PROTECTION $CMAKE_PYTHON $CMAKE_GNAP $CMAKE_COMPLETE
++cmake $SOURCE_DIR $CMAKE_PREFIX $CMAKE_SHARED $CMAKE_DEBUG $CMAKE_BACKUP $CMAKE_CROSS $CMAKE_PROTECTION $CMAKE_PYTHON $CMAKE_GNAP $CMAKE_COMPLETE $CMAKE_ICONV
diff --git a/utils/gammu/patches/002-no-fstack-protector.patch b/utils/gammu/patches/002-no-fstack-protector.patch
new file mode 100644
index 000000000..ec0badf2a
--- /dev/null
+++ b/utils/gammu/patches/002-no-fstack-protector.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -537,8 +537,6 @@ if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMP
+ # MACRO_TUNE_LINKER("-pie")
+ # These do not work on Windows right now
+ if (NOT WIN32)
+- # Stack protector
+- MACRO_TUNE_COMPILER("-fstack-protector")
+ # Mark code read only
+ MACRO_TUNE_LINKER("-Wl,-zrelro")
+ endif (NOT WIN32)
diff --git a/utils/gammu/patches/003-cmake-cross-toolchain.patch b/utils/gammu/patches/003-cmake-cross-toolchain.patch
new file mode 100644
index 000000000..cfacf1128
--- /dev/null
+++ b/utils/gammu/patches/003-cmake-cross-toolchain.patch
@@ -0,0 +1,43 @@
+--- /dev/null
++++ b/cmake/Toolchain-cross.cmake
+@@ -0,0 +1,5 @@
++# search for programs in the build host directories
++SET(CMAKE_FIND_ROOT_PATH_MODE_PROGRAM NEVER)
++# for libraries and headers in the target directories
++SET(CMAKE_FIND_ROOT_PATH_MODE_LIBRARY ONLY)
++SET(CMAKE_FIND_ROOT_PATH_MODE_INCLUDE ONLY)
+--- a/configure
++++ b/configure
+@@ -25,6 +25,7 @@ Usage: ./configure [options]
+
+ --help|-h shows this help
+ --prefix=<path> installation prefix
++--cross-root=<path> cross-compilation prefix
+ --enable-shared enables shared build
+ --enable-debug enables debug build
+ --enable-tiger enables Mac OS X 10.4 (Tiger) build
+@@ -50,6 +51,7 @@ SOURCE_DIR=`pwd`
+
+ # cmake parameters
+ CMAKE_PREFIX=
++CMAKE_ROOT=
+ CMAKE_SHARED=
+ CMAKE_DEBUG=
+ CMAKE_BACKUP=
+@@ -69,6 +71,10 @@ while [ "$#" -gt 0 ] ; do
+ --prefix=*)
+ CMAKE_PREFIX="-DCMAKE_INSTALL_PREFIX=${1##--prefix=}"
+ ;;
++ --cross-root=*)
++ CMAKE_ROOT="-DCMAKE_TOOLCHAIN_FILE=$SOURCE_DIR/cmake/Toolchain-cross.cmake"
++ echo "SET(CMAKE_FIND_ROOT_PATH ${1##--cross-root=})" >> $SOURCE_DIR/cmake/Toolchain-cross.cmake
++ ;;
+ --with-python=*)
+ CMAKE_PYTHON="-DBUILD_PYTHON=${1##--with-python=}"
+ ;;
+@@ -150,4 +156,4 @@ fi
+ cd "$BUILD_DIR"
+
+ # invoke cmake to do configuration
+-cmake $SOURCE_DIR $CMAKE_PREFIX $CMAKE_SHARED $CMAKE_DEBUG $CMAKE_BACKUP $CMAKE_CROSS $CMAKE_PROTECTION $CMAKE_PYTHON $CMAKE_GNAP $CMAKE_COMPLETE $CMAKE_ICONV
++cmake $SOURCE_DIR $CMAKE_ROOT $CMAKE_PREFIX $CMAKE_SHARED $CMAKE_DEBUG $CMAKE_BACKUP $CMAKE_CROSS $CMAKE_PROTECTION $CMAKE_PYTHON $CMAKE_GNAP $CMAKE_COMPLETE $CMAKE_ICONV
diff --git a/utils/gammu/patches/010-utils-shell-fix.patch b/utils/gammu/patches/010-utils-shell-fix.patch
new file mode 100644
index 000000000..d1b3ec35b
--- /dev/null
+++ b/utils/gammu/patches/010-utils-shell-fix.patch
@@ -0,0 +1,16 @@
+--- a/utils/gammu-config
++++ b/utils/gammu-config
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ # Gammu configuration generator
+ # Copyright (C) 2003 - 2009 Michal Cihar <michal@cihar.com>
+ # vim: expandtab sw=4 ts=4 sts=4:
+--- a/utils/jadmaker
++++ b/utils/jadmaker
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ # JAD file generator
+ # Copyright © 2008 - 2009 Michal Čihař <michal@cihar.com>
+ # vim: expandtab sw=4 ts=4 sts=4: