aboutsummaryrefslogtreecommitdiff
path: root/utils/fuse
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-01-08 19:59:49 -0800
committerRosen Penev <rosenp@gmail.com>2022-01-08 20:38:19 -0800
commit6710881cbd02d55909807d7e9ef4bb46ee9a8d06 (patch)
treed3061ee472e3fc252aa41c10c24a976e056d553f /utils/fuse
parente7547d980d21646009a3492b09c57ea62ffe0f22 (diff)
fuse: fix compilation with recent glibc
closefrom is implemented now. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/fuse')
-rw-r--r--utils/fuse/Makefile2
-rw-r--r--utils/fuse/patches/300-closefrom.patch20
2 files changed, 21 insertions, 1 deletions
diff --git a/utils/fuse/Makefile b/utils/fuse/Makefile
index 375c6b4a1..08059964d 100644
--- a/utils/fuse/Makefile
+++ b/utils/fuse/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=fuse
PKG_VERSION:=2.9.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/libfuse/libfuse/releases/download/$(PKG_NAME)-$(PKG_VERSION)
diff --git a/utils/fuse/patches/300-closefrom.patch b/utils/fuse/patches/300-closefrom.patch
new file mode 100644
index 000000000..a04f26cde
--- /dev/null
+++ b/utils/fuse/patches/300-closefrom.patch
@@ -0,0 +1,20 @@
+--- a/util/ulockmgr_server.c
++++ b/util/ulockmgr_server.c
+@@ -124,7 +124,7 @@ static int receive_message(int sock, voi
+ return res;
+ }
+
+-static int closefrom(int minfd)
++static int closefrom2(int minfd)
+ {
+ DIR *dir = opendir("/proc/self/fd");
+ if (dir) {
+@@ -384,7 +384,7 @@ int main(int argc, char *argv[])
+ dup2(nullfd, 1);
+ }
+ close(3);
+- closefrom(5);
++ closefrom2(5);
+ while (1) {
+ char c;
+ int sock;