aboutsummaryrefslogtreecommitdiff
path: root/utils/fuse
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-05-14 16:32:13 -0700
committerRosen Penev <rosenp@gmail.com>2020-05-16 17:26:30 -0700
commit45c37a235a250e3eef91fa69fc254142ac62cdcc (patch)
tree06cb26697761832da435a6195d2484a8ae03eaff /utils/fuse
parent348358bd50854ba2784c6b8ad46ef5369eddd1b5 (diff)
fuse: update to 2.9.9
Refreshed patches. Fixed license information. Minor adjustments. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/fuse')
-rw-r--r--utils/fuse/Makefile16
-rw-r--r--utils/fuse/patches/112-no_break_on_mknod.patch2
2 files changed, 11 insertions, 7 deletions
diff --git a/utils/fuse/Makefile b/utils/fuse/Makefile
index be80b03c4..90f1234c6 100644
--- a/utils/fuse/Makefile
+++ b/utils/fuse/Makefile
@@ -9,24 +9,24 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=fuse
-PKG_VERSION:=2.9.7
-PKG_RELEASE:=2
+PKG_VERSION:=2.9.9
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/libfuse/libfuse/releases/download/$(PKG_NAME)-$(PKG_VERSION)
-PKG_HASH:=832432d1ad4f833c20e13b57cf40ce5277a9d33e483205fc63c78111b3358874
+PKG_HASH:=d0e69d5d608cc22ff4843791ad097f554dd32540ddc9bed7638cc6fea7c1b4b5
-PKG_LICENSE:=LGPLv2.1 GPLv2
-PKG_LICENSE_FILES:=COPYING.LIB COPYING
+PKG_MAINTAINER:=
PKG_CPE_ID:=cpe:/a:fuse_project:fuse
PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
define Package/fuse/Default
TITLE:=FUSE
- URL:=http://fuse.sourceforge.net/
+ URL:=https://github.com/libfuse/libfuse
endef
define Package/fuse/Default/description
@@ -40,6 +40,8 @@ $(call Package/fuse/Default)
DEPENDS:=+libfuse
TITLE+= (utilities)
SUBMENU:=Filesystem
+ LICENSE:=GPL-2.0-only
+ LICENSE_FILES:=COPYING
endef
define Package/fuse-utils/description
@@ -57,6 +59,8 @@ $(call Package/fuse/Default)
DEPENDS:=+kmod-fuse +libpthread
SUBMENU:=Filesystem
ABI_VERSION:=1
+ LICENSE:=LGPL-2.1-only
+ LICENSE_FILES:=COPYING.LIB
endef
define Package/libfuse/description
diff --git a/utils/fuse/patches/112-no_break_on_mknod.patch b/utils/fuse/patches/112-no_break_on_mknod.patch
index f679c4116..863af6ae4 100644
--- a/utils/fuse/patches/112-no_break_on_mknod.patch
+++ b/utils/fuse/patches/112-no_break_on_mknod.patch
@@ -1,6 +1,6 @@
--- a/util/Makefile.in
+++ b/util/Makefile.in
-@@ -723,7 +723,7 @@ mount_util.c: $(top_srcdir)/lib/mount_ut
+@@ -736,7 +736,7 @@ mount_util.c: $(top_srcdir)/lib/mount_ut
install-exec-hook:
-chmod u+s $(DESTDIR)$(bindir)/fusermount