aboutsummaryrefslogtreecommitdiff
path: root/utils/fontconfig
diff options
context:
space:
mode:
authorMirko Vogt <mirko-openwrt@nanl.de>2016-08-29 20:15:32 +0200
committerMirko Vogt <mirko-openwrt@nanl.de>2016-08-29 20:16:08 +0200
commit41682a4258bf4f0db953c7ecd4452414a7bc45ba (patch)
treefdd6acab6278b9637a86390d234374dc8c39fa83 /utils/fontconfig
parent303febb30b6827db3d3e82f114c2b084ce48193d (diff)
package `fontconfig`
Diffstat (limited to 'utils/fontconfig')
-rw-r--r--utils/fontconfig/Makefile64
1 files changed, 64 insertions, 0 deletions
diff --git a/utils/fontconfig/Makefile b/utils/fontconfig/Makefile
new file mode 100644
index 000000000..7d0ef2dce
--- /dev/null
+++ b/utils/fontconfig/Makefile
@@ -0,0 +1,64 @@
+#
+# Copyright (C) 2008-2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fontconfig
+PKG_VERSION:=2.11.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://fontconfig.org/release/
+PKG_MD5SUM:=824d000eb737af6e16c826dd3b2d6c90
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/fontconfig
+ SECTION:=xorg-util
+ CATEGORY:=Xorg
+ SUBMENU:=font-utils
+ TITLE:=fontconfig
+ DEPENDS:=+libpthread +libexpat +libfreetype
+ URL:=http://fontconfig.org/
+endef
+
+#TODO: better put cache on persistent storage for faster boot time?
+CONFIGURE_ARGS+= \
+ --with-cache-dir=/tmp/fontconfig/cache \
+ --with-arch=$(ARCH) \
+ --disable-iconv \
+ --disable-libxml2 \
+ --disable-docs
+
+CONFIGURE_VARS+= \
+ ac_cv_prog_HASDOCBOOK=no \
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/fontconfig $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfontconfig.* $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/fontconfig.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/fontconfig/install
+ $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib $(1)/usr/share/fontconfig/conf.avail
+ $(INSTALL_DIR) $(1)/etc/fonts/conf.d
+ $(CP) $(PKG_INSTALL_DIR)/etc/fonts/fonts.conf $(1)/etc/fonts
+ $(CP) $(PKG_INSTALL_DIR)/etc/fonts/conf.d/* $(1)/etc/fonts/conf.d
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/share/fontconfig/conf.avail/* $(1)/usr/share/fontconfig/conf.avail
+ $(INSTALL_DIR) $(1)/etc/init.d
+# $(INSTALL_BIN) ./files/fontconfig.init $(1)/etc/init.d/fontconfig
+endef
+
+$(eval $(call BuildPackage,fontconfig))