aboutsummaryrefslogtreecommitdiff
path: root/utils/flent-tools/Makefile
diff options
context:
space:
mode:
authorToke Høiland-Jørgensen <toke@toke.dk>2016-09-14 13:33:18 +0200
committerToke Høiland-Jørgensen <toke@toke.dk>2016-09-14 13:33:18 +0200
commit4b7acb921f7045973249e89fff8afa793f9a8b1d (patch)
tree60ce1a49b60e21bff46b34531e9497f5c671165b /utils/flent-tools/Makefile
parent33646c1d055a4179452dd76038a81936fb8ab476 (diff)
flent-tools: Add package
This package installs a couple of helper programs for the Flent testing tool. These are useful when running tests and gathering remote data from an OpenWrt/LEDE router. Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk>
Diffstat (limited to 'utils/flent-tools/Makefile')
-rw-r--r--utils/flent-tools/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/utils/flent-tools/Makefile b/utils/flent-tools/Makefile
new file mode 100644
index 000000000..701fc504a
--- /dev/null
+++ b/utils/flent-tools/Makefile
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2007-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=flent-tools
+PKG_VERSION:=0.14.0-git
+PKG_LICENSE:=GPLv3
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REV).tar.gz
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/tohojo/flent
+PKG_REV:=272714a45c1cd25216ea772d40f35820323bfd79
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/flent-tools
+ SECTION:=util
+ CATEGORY:=Utilities
+ TITLE:=Helper programs for the Flent test tool
+ URL:=https://flent.org
+ MAINTAINER:=Toke Høiland-Jørgensen <toke@toke.dk>
+ DEPENDS+=+librt
+endef
+
+define Package/flent-tc_iterate/description
+ This builds the C helper programs for gathering data for
+ the Flent network testing tool. These tools are needed for
+ gathering data when a Bash shell is not available (and also
+ perform better than the shell equivalents).
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR)/misc \
+ CC="$(TARGET_CC)" \
+ CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
+endef
+
+define Package/flent-tools/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc/tc_iterate $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc/wifistats_iterate $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,flent-tools))