aboutsummaryrefslogtreecommitdiff
path: root/utils/flashrom/Makefile
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2020-04-16 20:30:55 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2020-04-16 23:43:08 +0300
commitf033cd1aedd04de0030cb2c41d905bade37f79d1 (patch)
tree457713fed920fc068830426d8c4b4a585ad80caf /utils/flashrom/Makefile
parentd2fd86663cf9166b9e52ef82fdc4f93b5ed0a9a8 (diff)
flashrom: bump to 1.2
Add new PCI and USB drivers to flashrom.mk to disable them in other build variant.s Fix DefineConfig calls to use new config symbols, and have it only append NEED_FEATURE=yes to MAKE_FLAGS. Appending NEED_FEATURE=no would still enable the feature because upstream compares against an empty string instead of comparing to yes. Drop libusb-compat dependency as all drivers use libusb-1 now. Remove upstreamed patch 010-add-arc.patch. Rework 0001-fix_internal_bitbang.patch, give it a correct prefix and more descriptive name. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'utils/flashrom/Makefile')
-rw-r--r--utils/flashrom/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/utils/flashrom/Makefile b/utils/flashrom/Makefile
index 937b48035..204a2413b 100644
--- a/utils/flashrom/Makefile
+++ b/utils/flashrom/Makefile
@@ -8,13 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=flashrom
-PKG_VERSION:=1.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.2
+PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://download.flashrom.org/releases
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_HASH:=3702fa215ba5fb5af8e54c852d239899cfa1389194c1e51cb2a170c4dc9dee64
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
+PKG_HASH:=e1f8d95881f5a4365dfe58776ce821dfcee0f138f75d0f44f8a3cd032d9ea42b
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
PKG_LICENSE:=GPL-2.0-or-later
@@ -46,7 +47,6 @@ define Package/flashrom
+(TARGET_x86||TARGET_x86_64):dmidecode \
+libftdi1 \
+libusb-1.0 \
- +libusb-compat \
+pciutils
VARIANT:=full
DEFAULT_VARIANT:=1
@@ -72,8 +72,7 @@ define Package/flashrom-usb
TITLE+= (usb)
DEPENDS+= \
+libftdi1 \
- +libusb-1.0 \
- +libusb-compat
+ +libusb-1.0
VARIANT:=usb
endef