aboutsummaryrefslogtreecommitdiff
path: root/utils/flashrom/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-05-13 19:14:20 +0200
committerJo-Philipp Wich <jo@mein.io>2018-05-15 07:39:20 +0200
commitcb6e98ba44c9cc8406f4d312d5cb7cf463e339d7 (patch)
tree3413a684c87b0e7fe380cd0a761bc9989dec19ad /utils/flashrom/Makefile
parentddaf94229ca56afab6772ac56b7d5686d9882826 (diff)
flashrom: update to v1.0
Update to flashrom version 1.0 and cherry-pick an upstream fix for deprecated libusb api usage. Fixes the following error spotted by the buildbots: ch341a_spi.c: In function 'ch341a_spi_init': ch341a_spi.c:447:2: error: 'libusb_set_debug' is deprecated: [...] libusb_set_debug(NULL, 3); // Enable information, warning and [...] ^~~~~~~~~~~~~~~~ In file included from ch341a_spi.c:25:0: .../libusb-1.0/libusb.h:1300:18: note: declared here void LIBUSB_CALL libusb_set_debug(libusb_context *ctx, int level); ^~~~~~~~~~~~~~~~ cc1: all warnings being treated as errors Makefile:1030: recipe for target 'ch341a_spi.o' failed Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'utils/flashrom/Makefile')
-rw-r--r--utils/flashrom/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/flashrom/Makefile b/utils/flashrom/Makefile
index df0561a2a..e2152b65b 100644
--- a/utils/flashrom/Makefile
+++ b/utils/flashrom/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=flashrom
-PKG_VERSION:=0.9.9.1
+PKG_VERSION:=1.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://download.flashrom.org/releases
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_HASH:=0e145a5b9b18c98752acf0f8329a9a260ddf030abf687416daab9f05a0f508d0
+PKG_HASH:=3702fa215ba5fb5af8e54c852d239899cfa1389194c1e51cb2a170c4dc9dee64
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_SOURCE_SUBDIR)