aboutsummaryrefslogtreecommitdiff
path: root/utils/eza
diff options
context:
space:
mode:
authorOskari Rauta <oskari.rauta@gmail.com>2024-02-28 20:32:24 +0200
committerTianling Shen <cnsztl@gmail.com>2024-03-05 11:41:48 +0800
commitdbb40471b72e84614d289a57e8dd4d8136798f7e (patch)
tree1e8917e62cb8609ade8a93c33d5d9b840a611c03 /utils/eza
parent867e7c2ccf803830f3f8099692cabaa4ce0b6703 (diff)
eza: add new package
eza is a substitute for ls command with icons and colors and more. Common for those who use ohmyzsh or similar shell stylers. Co-authored-by: Jonas Jelonek <jonas.helonek@proton.me> Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
Diffstat (limited to 'utils/eza')
-rw-r--r--utils/eza/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/utils/eza/Makefile b/utils/eza/Makefile
new file mode 100644
index 000000000..4e408a529
--- /dev/null
+++ b/utils/eza/Makefile
@@ -0,0 +1,46 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=eza
+PKG_VERSION:=0.18.5
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/eza-community/eza/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=9229b2111063577a0cb8650db270d0ae6bcc1b437dbacf814786f77c67b1003d
+
+PKG_MAINTAINER:=Jonas Jelonek <jelonek.jonas@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DEPENDS:=rust/host
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/rust/rust-package.mk
+
+define Package/eza
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=A modern, maintained replacement for ls
+ DEPENDS:=$(RUST_ARCH_DEPENDS) +zlib
+ URL:=https://eza.rocks
+endef
+
+define Package/eza/description
+ eza is a modern, maintained replacement for the venerable
+ file-listing command-line program ls that ships with Unix
+ and Linux operating systems, giving it more features and
+ better defaults. It uses colours to distinguish file types
+ and metadata. It knows about symlinks, extended attributes,
+ and Git.
+
+ And it’s small, fast, and just one single binary.
+endef
+
+define Package/eza/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/eza $(1)/usr/bin
+endef
+
+$(eval $(call RustBinPackage,eza))
+$(eval $(call BuildPackage,eza))