aboutsummaryrefslogtreecommitdiff
path: root/utils/dysk/Makefile
diff options
context:
space:
mode:
authorFacundo Acevedo <facevedo@disroot.org>2023-11-02 16:21:55 -0300
committerTianling Shen <cnsztl@gmail.com>2023-11-16 02:20:24 +0800
commit496a4f186a35cb132f3541e5b34c4b96cf934610 (patch)
tree6b1c9f916c5a7df6451c8b2075055eb4295b9201 /utils/dysk/Makefile
parent570bbc388516c59d07cf145a3d6fe8b58bd3b5b8 (diff)
Dysk: Add new package
Dysk is a command-line tool designed for efficient file and directory management in Unix-like environments Signed-off-by: Facundo Acevedo <facevedo@disroot.org>
Diffstat (limited to 'utils/dysk/Makefile')
-rw-r--r--utils/dysk/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/utils/dysk/Makefile b/utils/dysk/Makefile
new file mode 100644
index 000000000..cc559b083
--- /dev/null
+++ b/utils/dysk/Makefile
@@ -0,0 +1,41 @@
+# SPDX-License-Identifier: GPL-3.0-only
+#
+# Copyright (C) 2023 Facundo Acevedo
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dysk
+PKG_VERSION:=2.8.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/Canop/dysk/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=3e0f3a470539721748d7bc1acc867bdddcb824695b2f766e3a1f230ebac28c2c
+
+PKG_MAINTAINER:=Facundo Acevedo <facevedo@disroot.org>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENCE
+
+PKG_BUILD_DEPENDS:=rust/host
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/rust/rust-package.mk
+
+define Package/dysk
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Utility for efficient file and directory management
+ DEPENDS:=$(RUST_ARCH_DEPENDS)
+ URL:=https://dystroy.org/dysk
+endef
+
+define Package/dysk/description
+ Dysk is a command-line tool designed for efficient file and
+ directory management in Unix-like environments. It offers a
+ streamlined approach to organizing and manipulating files,
+ potentially simplifying various file-related tasks.
+endef
+
+$(eval $(call RustBinPackage,dysk))
+$(eval $(call BuildPackage,dysk))