aboutsummaryrefslogtreecommitdiff
path: root/utils/dumb-init/Makefile
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2020-10-26 16:31:30 +0100
committerRosen Penev <rosenp@gmail.com>2020-10-26 21:48:17 -0700
commit62cd5a3d9a280a99af79fb37e52ddbec93ce05e2 (patch)
tree0cfc137231638423947c8caedd1e9549c9b93119 /utils/dumb-init/Makefile
parent3fa36bf958ead54eb8d16bb9c083bb03983d65a3 (diff)
dumb-init: add package
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'utils/dumb-init/Makefile')
-rw-r--r--utils/dumb-init/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/utils/dumb-init/Makefile b/utils/dumb-init/Makefile
new file mode 100644
index 000000000..33a41c501
--- /dev/null
+++ b/utils/dumb-init/Makefile
@@ -0,0 +1,37 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dumb-init
+PKG_VERSION:=1.2.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/Yelp/dumb-init/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=d4e2e10e39ad49c225e1579a4d770b83637399a0be48e29986f720fae44dafdf
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Toni Uhlig <matzeton@googlemail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+
+MAKE_FLAGS+=CFLAGS='$(TARGET_CFLAGS) $(TARGET_LDFLAGS)'
+
+define Package/dumb-init
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=dumb-init
+ URL:=https://github.com/Yelp/dumb-init.git
+endef
+
+define Package/dumb-init/description
+ dumb-init is a simple process supervisor and init system designed to run as
+ PID 1 inside minimal container environments.
+endef
+
+define Package/dumb-init/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/dumb-init $(1)/usr/sbin/dumb-init
+endef
+
+$(eval $(call BuildPackage,dumb-init))