aboutsummaryrefslogtreecommitdiff
path: root/utils/dosfstools
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-05-19 16:38:55 -0700
committerRosen Penev <rosenp@gmail.com>2019-05-19 16:38:55 -0700
commit28a18b8eccfa478dc2028363e70bed32977ea3a3 (patch)
tree2e96a2e51a55e69a9b4ca5506d0651906a26bc52 /utils/dosfstools
parentc2870de91fc0ef6458640bb660e33f35b8bdcad0 (diff)
dosfstools: Fix compilation with full NLS
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/dosfstools')
-rw-r--r--utils/dosfstools/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/utils/dosfstools/Makefile b/utils/dosfstools/Makefile
index 52d050c4b..0fc31c772 100644
--- a/utils/dosfstools/Makefile
+++ b/utils/dosfstools/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dosfstools
PKG_VERSION:=4.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/dosfstools/dosfstools/releases/download/v$(PKG_VERSION)/ \
@@ -42,6 +42,8 @@ define Package/dosfstools/description
The dosfstools package includes the mkfs.fat and fsck.fat utilities, which respectively make and check MS-DOS FAT filesystems.
endef
+TARGET_LDFLAGS += $(if $(ICONV_FULL),-liconv)
+
define Package/dosfstools/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/fatlabel $(1)/usr/sbin/