aboutsummaryrefslogtreecommitdiff
path: root/utils/domoticz/Makefile
diff options
context:
space:
mode:
authorAmol Bhave <ambhave@fb.com>2019-05-08 21:34:22 -0700
committerStijn Tintel <stijn@linux-ipv6.be>2019-06-05 10:59:12 +0300
commita73b3b2d753fa4734cec0c8a3effa910fe550f71 (patch)
treef4c009bcdd49f993faae477e33d3944fa25749de /utils/domoticz/Makefile
parentb93d39ac744529210e61c45d9d35a2e95e4813ef (diff)
domoticz: disable searching for boost-cmake
Summary: This package fails to compile with boost 1.70 when the boost cmake config gets used. As far as I can tell, Boost 1.70 introduced BoostConfigVersion.cmake. In that file, the value of PACKAGE_VERSION is set to 1.70. This makes CMake auto set the variable Boost_VERSION to 1.70. Historically, Boost_VERSION has been using the format like 170000, and not 1.70. Some package cmake files still depend on this behavior and make assertions such as Boost_VERSION > 168000. This is incompatible with the new scheme. Test Plan: `make package/domoticz/compile` Also compiled all other packages that have a boost dependency, they seem to be working fine. tested on nbg6817 Signed-off-by: Amol Bhave <ambhave@fb.com> [split unrelated change, change commit subject, alphabetical order] Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'utils/domoticz/Makefile')
-rw-r--r--utils/domoticz/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/utils/domoticz/Makefile b/utils/domoticz/Makefile
index 9f66981ba..7bd2ae06b 100644
--- a/utils/domoticz/Makefile
+++ b/utils/domoticz/Makefile
@@ -12,7 +12,7 @@ PKG_VERSION_MAJOR:=4
PKG_VERSION_PATCH:=9700
PKG_COMMIT:=
PKG_VERSION:=$(PKG_VERSION_MAJOR).$(PKG_VERSION_PATCH)
-PKG_RELEASE:=2
+PKG_RELEASE:=3
ifeq ($(PKG_COMMIT),)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -63,6 +63,7 @@ endef
CMAKE_OPTIONS += \
-DBUILD_SHARED_LIBS=yes \
+ -DBoost_NO_BOOST_CMAKE=yes \
-DCMAKE_BUILD_TYPE=Release \
-DUSE_BUILTIN_MQTT=no \
-DUSE_BUILTIN_SQLITE=no \